Volumio 1.4 for Cubietruck Feedback thread

Guys, since this is a new platform, feedbacks are quite important to let me understand if I made a good work or not! So please report here how is your experience with Cubietruck (and please be kind, let me go to seaside sometimes… lol).

Hi Michelangelo,

Thanks for this distro.

Due to the versatility of the Cubietruck 4 audio devices aren’t enough…

5 are needed, the 5th is USB audio (D20)…

I’ve changed mpd-config.php:

[code]//output device names
$dev1 = file_get_contents(’/proc/asound/card0/id’);
$dev2 = file_get_contents(’/proc/asound/card1/id’);
$dev3 = file_get_contents(’/proc/asound/card2/id’);
$dev4 = file_get_contents(’/proc/asound/card3/id’);
$dev5 = file_get_contents(’/proc/asound/card4/id’);

// output devices selector
$_mpd_select[‘device’] .= “<option value=“0” “.(($_mpd[‘device’] == ‘0’) ? “selected” : “”).” >$dev1\n”;
$_mpd_select[‘device’] .= “<option value=“1” “.(($_mpd[‘device’] == ‘1’) ? “selected” : “”).” >$dev2\n”;
$_mpd_select[‘device’] .= “<option value=“2” “.(($_mpd[‘device’] == ‘2’) ? “selected” : “”).” >$dev3\n”;
$_mpd_select[‘device’] .= “<option value=“3” “.(($_mpd[‘device’] == ‘3’) ? “selected” : “”).” >$dev4\n”;
$_mpd_select[‘device’] .= “<option value=“4” “.(($_mpd[‘device’] == ‘4’) ? “selected” : “”).” >$dev5\n”;

Thanks for your efforts…

lol, I added one more just for cubietruck… And it isn’t enough… lol

thanks for this report, I’ll add 2 more, so we’re fine. As for the rest? What do you think?

I’ve found a playlist bug/problem.

When a song is finished it gets removed from the playlist.
The same happens when you click the next button.

Another problem: when I stream from my iPhone, iPad, PC or LAPTOP via airplay, the sound is very distorted.
It sounds like a very oversteered Mickey Mouse.
After disconnecting airplay the functionality is gone, even after a reboot and after disabling and enabling airplay in the settings page, but only on the iPhone, LAPTOP and PC. The iPad 3rd gen can still connect via airplay. PC (wired) and LAPTOP (wireless) are running Windows 8.1 pro. iPhone iOS 7.1.1 (not jailbroken), iPad iOS 7.04 (jailbroken). Another ipad 3rd gen with iOS 7.1.1 (not jailbroken) also can’t connect.

When logging in via SSH it takes quite a long time. It can be fixed with by editing /etc/ssh/sshd_config.
At the end add UseDNS no. After a reboot it should work fine.

On iOS devices the time isn’t updating.
This is caused by a bug in jquery.countdown.js version 1.6.2.
version 1.6.3 works great.
You can download it at: http://keith-wood.name/zip/jquery.countdown.package-1.6.3.zip

The sound quality when playing music from my NAS is very good.
Volumio on a Cubietruck has lots of potential!

The Cubietruck has a dualcore processor.
Maybe you can include an option to bind mpd to one processorcore and give it a high priority. Some say it benefits the sound quality.
I’m not sure about that. But it is plausible.

sudo chrt -f -p 81 $(pidof mpd) taskset -c -p 1 $(pidof mpd)
Binding nginx to another core could also be beneficial. (If nginx hangs, it shouldn’t affect the other core)

An extra option is to give mpd the highest niceness possible, (via editing /etc/init.d/mpd)

Enough for today, and again: thank you for Volumio. :smiley:

Thanks LeonCB! This was quite a feedback!
To quote: I’ve experienced your same issue of mickey mouse sound on UDOO Quad, analog out, is this happening on Cubie on Analog out?
Then, applying highest niceness to mpd has controversial effects: on some setups gives benefits, on others will make system unstable.
As for songs removed from playlist, just remove consume mode (the bin icon in playback tab).
Thanks for the others, they are quite helpful!

Hi Michelangelo,

i don’t know if here is the most appropriate place to report it, but i have the exact same problem with Volumio 1.4 (with both original kernel and new kernel to fix wifi) installed on a Cubox-i4P. The cubox is connected via USB to my DAC/amp.


It happens on USB audio. Others not tested yet. Will test it in a few days.

I personally never had an issue with highest niceness, but i’m not convinced it benefits the sound quality though.

Overlooked the consume mode button. It works. Thanks!

Hi there,

thanks for the great work and the support for the Cubie … though I have an issue with my USB-DAC (Burmester 113) - it is not recognized at all. Before doing some more investigation later I wanted to know if someone else had the same problem as my DAC works fine with Volumio on the Raspi and the BeagleboneBlack.

Edit: Got it - has to be powered via 5V input and not via USB.
Now I can do some further testing & listening :slight_smile:


Hi Michelangelo,

The distored mickey mouse sound occurs only on USB audio.
Analog out and HDMI are ok.

i2s not tested.

Tested it om my iPhone and my iPads.
iTunes on laptop and PC doesn’t. Airplay not available.
My old airport express does show up on iTunes on both laptop and pc and is working fine.

After multiple cache cleanup of Chrome,Firefox and Opera i have not the new U.I ''Library Browsing Tab" ,you another user Cubietruck you have the tab ‘Library’ between ‘Browse’ and 'Playback"?.

I connected the Cubietruck in I2S, with UFL cable to Ian FIFO card ,works very well (16-44khz-24-96khz-24-192khz),with a wifi connection.The largest difference compared to usb is in the medium more open and dynamic.Now finishes, clean connections (U.F.L to U.F.L).



Hi all!

Has anybody experience with I2S connection between cubietruck, Hifiberry DAC, DIGI or G2Labs BerryNos DAC? My 'truck will arrive tomorrow and of course I want to test it excessively :mrgreen:


What I meant is, are these DAC’s supported? I can activate I2S as I saw but does this create a usable connection with the boards?

The realization of an I2S connection with cubietruck physically would also be good to know. Who did it and want to help me saving time? :mrgreen:


look two posts above :smiley: and http://hifiduino.wordpress.com/2014/03/07/cubieboard-for-audio/

Thanx, clsidx!

Your name looks as complicated as the i2s modifications :mrgreen:
Does that mean, that i have to desolder some smd resistors (that I wouldn’t like to do) or could the changes be realized via jumpers.

Then there is only the DAC compatibility question left (concerning volumio).

A new adventure will make me sleepless :mrgreen:

Hi Michelangelo!

Just have tested my brandnew cubietruck that arrived today. Within half an hour everything worked via spdif toslink and an external dac.
I use the internal wlan of the truck and have an external HDD connected via USB. Sounds good and Volumio 1.4 performs well now.

But: 1) After powering down the truck the HDD does not shut down automatically. I have to plug off the extra psu of it.

   2) I've tried ram-load- but tracks are loading very slow. Further more the ram space only delivers 256MB (like with the pi)
       Truck has 2GB, there must be something left untouched.

Is there a workaround for this 2 problems so that I can do the change?


Greetingz, Robert

If you load files on RAMPlay via Wireless LAN, the maximum tranfer speed is what your LAN allows (which in the better scenario is 3mb/s). To achieve better speeds just use Ethernet connection, both on your PC and Cubietruck. To extend the RAMplay partition, just edit


Changing 256 to 1400 (better stay on safe side here, tough I think you can go up to 1700 safely…

Thanks Michelangelo!

Then there is only problem 1) left: External USB drive doesn’t automatically power down
after cubietruck shutdown. The same drive was connected to the pi before where this problem didn’t occur.

Is this a hardware based problem or solvable via changes in volumio?

Everything else works fine so far with 1.4 after testing it several hours.

Greetingz, Robert

Hi all!

There’s another issue with 1.4 and cubietruck. If I do upsampling to 24bit 96khz I’m not able to choose other sink interpolators than ‘fastest’. That is as I think also left untouched from raspi version. But cubietruck should be able to handle higher levels, or not?

Another question in this relation is if cubietruck is able to transfer 24bit/96khz via spdif toslink. Usually this works with toslink.

Has anybody an idea or experience?


Greetingz, Robert

Hi, does anyone have simple instructions on installing Volumio on the Cubietruck’s SD?

I’ve followed the steps on the site by using dd on my Mac but the Cubietruck still boots into NAND instead. I read some errors as it was booting up about mmc, but it did detect my 16GB Class 10 microSD card.

Cubiuntu’s Disks utility could detect the card as FAT formatted but everything else was Unknown, unmountable.

Any help would be greatly appreciated!