Volumio 1.4 bugs

Hi Michelangelo!

Thanks for upgrading to 1.4 and the big effort you’ve made!
But- to be honest:
1.4 to me is very slow in some aspects.

  1. If I change from some menu points back to ‘playlist’ on the bottom it takes a long time to view playlist again.
  2. Edimax wifi dongle again needs disabling power management ('cause of dropping connection)- ok- that was no problem.
  3. The ‘Library’ button on the bottom is totally useless for me- it takes very long time to have a view on the data and in the end the result makes no sense to me. I’m playing wav because I think it sounds best- better than flac- and nothing will change my opinion in this case.
    Maybe that’s the reason why this function delivers nothing positive to me. A gimmick, nothing more, very slow and definitely useless to my opinion.
    The bottom button ‘browse’ fullfills my needs completely.
  4. When I changed back to volumio 1.2 I wasn’t able to use the ‘back’ function anymore when USB or WEBRADIO browsing- very strange. Instead of that the button ‘files’ was shown with no functionality at all.
  5. If I save a playlist I’m not able to delete it. It is shown below USB and WEBRADIO with no possibility to quit it- probably I’m not able to remove it 'cause of lacking knowledge.
    Sorry, Michelangelo for critics- but I think it will contribute to progress.

One more question: What are the upnp; upnp/dlna functions for? I’ve no idea :blush:
Conclusevely: Would I be able to play BERRYNOS 1543 DAC from G2 Labs with 1.4?- 'cause this DAC really gives me the kick!

BUT- in the end sound is fine! :smiley: That’s the most important thing to me with volumio- so I’ll stay with 1.4! No gimmicks- just sound perfection- that’s what I’m expecting from VOLUMIO. There are enough players around that are based on features, features, features- with degraded sound.
My aim is the concentration on pure HIGH END as the main ambition.

Greetingz- and sorry for complaints


Bug report on Volumio 1.4 continued:

  1. Generally comparably slow reaction.
  2. Is solved. Edimax dongle works without any problems now, I just had to disable power management that was described here some time ago.
  3. No improvement to the ‘Library’ Function at the bottom. Has no function for me. Incomplete listings; very slow. I try hard not to touch this button.
  4. Solved: After changing to 1.2 again there was no ‘back’ button anymore. This only mattered my smartphone. The button returned after deleting ram and clearing some data fragments.
  5. No solution also in this point: I am unable to delete stored playlists. They stay with their given names in the ‘Browse’ area.

Moreover there are sometimes problems in changing radio stations- it may occur that volumio stucks especially when changing from a lower quality supplier to for example linn radio with there 320kbps quality.

In addition i recognized that playing with 512 Kb buffer adjustment and disabled ‘buffer before play’ as I did it with 1.2 leeds to drop outs in the beginning of playing or cracks when changing tracks now with 1.4 so I had to increase this values. That means that 1.4 version works slower than 1.2 what to my understanding raises CPU load and this fact is potentially sound degrading.

But apart of that- sound is good!
Besides: I’m currently playing with the Pi and a Digi

Greetingz, Robert

Generally the same experience from my side. It just feels a bit slower and library doesn’t do very much. Mostly gives the running ‘waiting’ circle. Might be because of a fairly large music collection (guess around 180GB, 25k files)?
Haven’t tested the playlist saving behaviour, will test this tonight. Displaying the playlist tab might take several refreshes from the interface.

I’ve been seeing this problem where many albums will not play. I can ‘add, replace, and play’ them but the player just skips through them very quickly and never plays anything. It’s no limited to specific file formats. My library has MP3, AAC, Apple Lossless, WAV, AIFF, and FLAC and pretty sure I’ve seen this behavior with most of those.

In its current state, the library is a bit weird but I like the OS X-style ‘columns’ view. However, sometimes the browse tab appears to be non-responsive until the library finishes loading. Right now, “php5-fpm” from user “www-data” is using over 80% CPU on the Raspberry Pi. I wonder if the library is too much for the Pi? How does Volumio respond to overclocking?

Offtopic but I’m pleased to see that support for Cubietruck is in the works. I’ve been considering buying one.

I think we could work on a setting to enable / disable library, as I understand it doesn’t make sense for everyone.

plasmapizza, can you tell me how many songs you have in your library? I’ve tested it with about 3200 titles and didn’t experienced any problem (apart from having to wait a few seconds for loading), but maybe if you have far more songs it’s not as stable.

A “delete” function could probably be implemented for playlists… For the time being, as a workaround you can connect with ssh to your pi and see (delete) playlists under /var/lib/mpd/playlists

I was thinking the same. Furthermore, with Raspberry PI and slower platforms this causes lot of load. We should also make it responsive and make it somehow lighter if possible.

Somewhere between 8000 and 9000. My iTunes library is 8600, and I’ve added a bunch of stuff to Volumio that I don’t have in iTunes.

I’ve just run raspi-config to overclock slightly. Let’s see what that does.

I’ve used voumio with Pi since Raspyfi days. Can’t get sound via USB through my Topping TP 30, any ideas (previous versions worked out of the box)

I have a little bit more files in my library, but browsing the folders is pretty fast.

But I’ve got another problem, my “Library” tab is showing nothing…
Tried several browser clearing cache and reloading, updating folders and rebooting the pi.
Tags must haven been recognized correctly since they are showing up in “Folder view” and while payback.

Hi Michelangelo,

I’m using Cubox-i4P. There seems some issues on ver 1.4:

  1. The play list tab is missing
  2. The library tab is in forever loading circle ever since the 1st boot up without adding any music library.
  3. I found that for unknown reason the system time once set to 1927 which caused the DHCP to unable to bring up ethernet. I need to set it back to current time using a USB keyboard to enable the eth0. Is it possible to fix it in the next release?

Other than the above I don’t have much complain. The sound quality is wonderful using Volumio and Cubox-i4P.

Thank you very much for bringing such a wonderful piece of software to us.

HI, i’m gonna post my 1.4 test results here too:

here is my setup :
Raspberry Pi model B
Cambridge DacMagic (usb wired -> C-Media chip)
Lacie USB HDD 500Go
Wired ethernet connection

1.Install & config : no problem

2.Access to Web UI: no problem

3.Building Library: pretty long process (over 28K files in many formats) but no error displayed everything seems to be fine

4.Library usage:
-via WebUI, library is empty (only All genres / All Artists / All Albums) nothing clickable (tried to update , delete, re create, nothing change also tried different browser / computer))
-via MPoD (iphone4), library loads fine and all my files are well presented
-via MiniDLNA , display some empty folders (browse and music)

5.Browsing Tab usage: Fast and reliable, quickly add & play files, just what i needed !

6.Shairport usage : everything is fine here, no pop, no distotion and almost in sync. (tried from osx, iphone and win7 itunes)

Sound quality is pretty good the only big troubles are the weird behaviour of the library tab and the minidlna empty database,

Library tab : seemed to work fine if i click it during the indexing process, but always empty when indexing is over… checked Tag_cache size around 5MB and all my files are well displayed in MPoD…
miniDlna : can’t index my files, or crash during index if i point minidlna.conf directly to my usb hdd (saying databse is malformed)

I would like to play music from the database to a remote computer but i didn’t manage to do it, can someone point me in the right direction?

Otherwise it’s a great piece of software, thank you^^

Ps: sorry for my not so good english ^^

I’m using a Cubox-i4pro, and it seems as though the broadcom 802.11n kernel modules were not included in the release. They were included in v1.2beta.


root@volumio:~# dmesg |grep brcm
root@volumio:~# ifup wlan0
wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
Internet Systems Consortium DHCP Client 4.2.2
Copyright 2004-2011 Internet Systems Consortium.
All rights reserved.
For info, please visit https://www.isc.org/software/dhcp/

Cannot find device "wlan0"
Bind socket to interface: No such device
Failed to bring up wlan0.


volumio@volumio:~$ uname -a
Linux volumio 3.10.30-15-ARCH #1 SMP Thu Apr 10 07:50:43 MDT 2014 armv7l GNU/Linux
volumio@volumio:~$ ls -l /lib/modules/$(uname -r)/kernel/drivers/net/wireless
total 28
drwxr-xr-x 4 root root 4096 Apr 20 11:05 ath
drwxr-xr-x 2 root root 4096 Apr 20 11:05 b43
drwxr-xr-x 2 root root 4096 Apr 20 11:05 b43legacy
drwxr-xr-x 4 root root 4096 Apr 10 13:51 brcm80211
drwxr-xr-x 2 root root 4096 Apr 20 11:05 rt2x00
drwxr-xr-x 3 root root 4096 Apr 10 13:51 rtl818x
drwxr-xr-x 5 root root 4096 Apr 20 11:05 rtlwifi


root@volumio:~# uname -a
Linux volumio 3.0.35 #1 SMP PREEMPT Sat Feb 8 09:07:48 PST 2014 armv7l GNU/Linux
root@volumio:~# ls -l /lib/modules/$(uname -r)/kernel/drivers/net/wireless
total 4
drwxr-xr-x 3 root root 4096 Jun 17 01:14 ath

For what it’s worth, I’ve gone back to 1.2, as 1.4 can’t mount the NAS when given the same settings as 1.2. Any logs I could provide that would be of any help?

Chris M

Hi Michelangelo,

i would like to report two bugs that unfortunately prevent me from using Volumio 1.4 on my Cubox-i :

  1. internal wifi does not work as mentioned by blueroom :cry: (why not adding the driver for popular USB Wifi dongle like the Edimax ? I absolutely need a wireless connection in order to be able to access the songs stored on my NAS away from my audiophile installation)

  2. the package dependencies that are broken since Volumio 1.3 and that prevent using apt to install some new software (I need this feature to be able to stream the artworks contained in my mp3s’ ID3 Tags to the mobile MPD remote i’m using)

Thank you for your hard work

Crossing my fingers for a future release :slight_smile:


Bug in V1.4: there is a /etc/raspyfi.txt file!
Also: why is Mutt installed by default? not very useful in Volumio. I would rather provide the tool to turn off the ethernet LED.

I added “ro,sec=ntlmv2” to the NAS share options but I still cannot access my share!

I appreciate the work done on the distro but this problem, still there after so many complaints, is really annoying.
Can it be solved? so that I put it in the script I am preparing and other people will get it too.

Where is located the Library config file with the NAS share settings? When I use the GUI the advanced option sec=ntlmv2 is not kept!


Fantastic Music with Volumio 1.4 and Cubox i4.

I have only one issue. Shairport produce no sound. With the version 1.2 Beta, in this forum I found a “parade”.

So I’m waiting this bug will resolve and the word of music will be the best quality/price I known


That’s really weird. My Cubox-i4’s wlan works perfectly. Maybe mine has a different Wireless adapter. When your wi-fi works, could you please tell me which module is loaded? And the name of the adapter?