volumio 1.2 can not reconnect after a few hours

Hi there,

I have installed volumio 1.2 on a Pi with Hifiberry. I am using an Ethernet connection, no Wifi. It works and sounds fine. But after a few hours I can not connect to it anymore. Neither through a browser nor through a terminal connection. The only solution is to power cycle the Pi. This was not the case with volumio 1.1.

Any idea?




I have a similar problem with Volumio 1.2.

My setup is :
Raspberry Pi model B
SD Card 4GB
Ethernet connexion

When I add my NAS in Volumio (SMB), everything works perfectly.
However, after some minutes of use, the music stops and the web interface is down.

The SSH access is still operational but seems to be slow.
Airplay also work at this time.

If I run the following CLI, Airplay do not work anymore :
sudo apt-get update

The only way to make the Volumio Web Interface working again is to flash again the SD card with a new Volumio installation…

I also tried to add the NAS share manually (like on this page : volumio-update-t790.html). It works but the web interface is still down after some minutes of use.

If I do not add any share on Volumio, Volumio seems to be stable.

Best Regards,

got the same Problem, with wifi. i will test ethernet today. Are you on a raspberry too?


hm, i will test Volumio with no nas-share too.


I have the same problem with Volumio 1.2 beta, Raspberry pi B, NAS WD with an ethernet cable after some hours or after a reboot.
I can access to the RPI with SSH and I can use the http server with RPI-Monitor but not with volumio or with a MPD Client.
I notice the MPD daemon is not started.
So if I start the MPD daemon twice

sudo service mpd start sudo service mpd resrart
and after few minutes I can use the http Volumio and the MPD Client.

Hello again,

i just tested it. Even if i flash a fresh Volumio and change anything, i lose connection (over ethernet in this case) after some minutes (!). Putty/shell doesn’t work anymore too, same symptom as the op got. If i plug in HDMI, i see the standard Volumio screen, so the system itself is still working.

So, does anyone got Volumio on the Raspberry working?

If so, maybe it’s the powersupply (5v, 2A Dell tablet charger) fault?


Works perfect with my new digiberry and my M1 DAC. No Pops… Nothing !!!


Gesendet von meinem Nexus 7 mit Tapatalk

Hello, thanks for the feedback, it motivates me for further investigation. :slight_smile:

I detached the Hifiberry and the connection is stable since ca 1h. I think the Powersupply is the problem. Unfortunatly the battery from my meter is dead, if i have a new one i will measure the TPs on the raspberry.

Edit: My joy was to early. After some hours, the connection was lost. I now doubt it is a power issue.

If i unplug and re-plug the ethernetcabel, the connection is immedately established. So i wonder if there is any standbymode or something for the network components?

i made some measurements between TP1 and TP2 at the raspberry, respectively after complete boot.
Measuring device: Peaktech 2010 DMM

Following things are connected:

  1. HDMI, Powersupply -> 5.01 V
  2. HDMI, Powersupply, LAN -> 5.00 V
  3. HDMI, Powersupply, Hifiberry -> between 5.00 V and 5.02 V
  4. HDMI, Powersupply, Hifiberry, LAN -> between 4.99 V and 5.00 V
  5. HDMI, Powersupply, Hifiberry, LAN, WLAN unconncted -> between 4.89 V and 4.92 V
  6. HDMI, Powersupply, Hifiberry, LAN, WLAN unconncted, Keyboard -> same like 5.
  7. HDMI, Powersupply, Hifiberry, LAN, WLAN conncted -> between 4.89 V and 4.90 V

I think the values are good and i can exclude a powersupply issue.

Any other suggestions?

Edit: I tested Volumio 1.1 and it seems that the networkconnection is far more stable. With a connected USB-storage i still got problems, but with a SMB-mount it seems to work good (not tested for over 24h operating).

I have the exact same problem, also on a PI.

I can confirm this.

I have the same problem not being able to connect at all. I’ll try the trick of unplugging and reconnecting the ethernet cable.

I’m also going to get the 1.1 image back on the system, as I had better luck with that version.




Got 1.1b back on the system and listening to webradio via wifi (Edimax).

I can see the BBC stations I loaded into a BBC folder, but can’t hear them when I click into playlist. Interestingly the pre-loaded stuff works fine.

EDIT - Just recopied into folder and work fine. It was my renaming to Radio 1 etc that seems to have done the damage. All good now, but odd file names like: r6_aaclca

I am leaving this config for a while as it works. Still can’t mount my NAS. I suspect it might be an issue with my TP-Link router.

I do wonder it a retrograde to 1.1 might be helpful at the moment.



Just a quick feedback from me:
I’m still on 1.1 with wlan-connetion and over a bunch of days i had to restart the raspberry only once. Now i am satisified, though the volume control isn’t working. But for me this is a minor problem.

this is by all means a workaround
within the infinite loop, it will check if mpd is alive (using mpc), if not it will restart mpd

diff --git a/command/player_wrk.php b/command/player_wrk.php
index f488c07..dc38db6 100755
--- a/command/player_wrk.php
+++ b/command/player_wrk.php
@@ -287,6 +287,7 @@ if (isset($_SESSION['cmediafix']) && $_SESSION['cmediafix'] == 1) {
 // --- WORKER MAIN LOOP --- //
 while (1) {
+sysCmd('mpc > /dev/null 2>&1 || service mpd restart > /dev/null');
        // monitor loop
        if ($_SESSION['w_active'] == 1 && $_SESSION['w_lock'] == 0) {

Same problem here and can also confirm the re-plugging of cable to solve it. Today I ran rpi-update and it has been running for over four hours now (before the longest uptime I had was below two hours). I’ll keep it on over the night and make a new post tomorrow.

Still running! 15 hours without loosing connection now. The firmware update seems to have solved it for me.


I had a similar problem: losing connection after 5-10 minutes of inactivity. I confirm that rpi-update seems to have resolved the issue.

I had the same problem, but tried aateck’s solution and it worked perfectly.

Logged in with Putty and ran
sudo service mpd start
sudo service mpd restart

The web interface came up instantly and the devise is playing like a champ.