Volume really low on ODAC + Pi3 or Odroid C2

I have a JDS labs ODAC Rev. B and when using it on my PC, I get normal volume levels.

When I run Volumio on both my C2 and my Pi3, I have the same issues. I disable the volume control since I use my amps volume, but I have to turn it up so loud just to get anything its almost not usable.

Has anyone else had this issue and what did you do to solve it?



I had the same problem with ODROID XU4, CubieTruck 3, Cubox I4 and finally Raspberry 3 Model B with the ODAC Rev B. The Output Level was only 140 mV instead of 2.1 V. The old ODAC Rev A works out of the box.
But there is a simple solution. You only have to go into the ALSA driver look to the number which references to your ODAC and increase the related controller level to 100%. Right now I am in the office and I don´t remember those commands, but I will give them to you in the late afternoon. That will work with Volumio 1.5 and 2 :smiley:

Have a nice day

where and how do I go into this ALSA driver???

Hi Neccros,

I just came home. Here is a way to fix it:
Go via SSH (for Example PuTTY) into your Raspberry. Or hook up a monitor and a keyboard to your Raspberry.
Login and password are both “volumio”.
On the command line type: “cat /proc/asound/cards”

This will show you your soundcards. Look for [ODACrevB ] and notice the number which stands directly in front of the [ODACrevB ]. Mine for example is number 5!

Then type “alsamixer -D hw:5” where you put your noticed number after the hw: .

You will see a graphic with 2 Lines: PCM and Softmaster. You can go with your cursers (left right) to select PCM and then go with curser (up down) to select the maximum level (100).
You can leave with escape and it should be done.
All of my machines (see signature) are remembering this setting after reboot.
Hope it helps. :sunglasses:

Is this a bug in volumio or issue with the DAC? Sucks I have to keep doing this every time I setup a new install.

Sent from my Nexus 5 using Tapatalk

I don´t know, if it is a bug in voumio. I am a noob with linux and I can´t really tell you.
I had contact to a developer from JDSLabs and he told me, that the ODAC Rev B should be the same as Rev A regarding the behavior on the usb port. But: when I hook up a Rev A ODAC I don´t have to go into ALSA and everything is working out of the box…
And this happens on all my machines including an ODROID XU4. But you only have to do this once for your operating system.
I can live with that workaround.

Yeah I tested this on my Odroid C2 and got the same results… Maybe I will borrow another DAC and test it out

Or hook it up via HDMI to my AVR and have the internal DACs decode it and see what happens

Well this helped. Still a little quiet compared to my PC desktop…

The Odroid C2 seemed to be louder doing the same thing… I also tried an Audioengine D1 DAC/amp and it started clicking and couldn’t even tell it was playing music… Then got it to play somehow and just constant skips, etc…

Volumio just seems unfinished… Nothing I have seems to work well with it so I might just leave it alone for another few years like I did before and see if it gets better by then.

I had this same issue with a JDS Labs EL DAC. Luckily I was able to borrow a spdif board from a friend so I stopped worrying about it.

Same issues as my D1???

Using USB, my EL DAC played at much lower volume from my RPi than it did from my Mac. Luckily the EL DAC has a 3 different inputs and the Toslink connection from Hifiberry Digi plus Pro is fine. The info on JDS website gives me the impression that the EL DAC is basically an upgraded ODAC.

I think it is a different design since the ODAC was open sourced from NWAVGUY and his rules were you couldn’t mess with the design

What sucks is I want to try a Hifiberry DAC but hate to sink more money into this project when It may not work either…

I don’t think you need to worry about that. The Hifiberry DAC will avoid using USB where I suspect the problem is. People seem to have very mixed results using USB audio on the RPi.