Volume control on Khadas tone board stopped working

Hello,

I have a Pi4 4GB with Khadas tone board.
Everything worked very well until yesterday when I faced a very strange behaviour.

I tried powering the TB with a separate 5V transformer using a Y cable where only pin 1/4 (power) where active on the transformer side, while on the Pi only ground (4) and data (2/3) where active.
The reason for this was that I have an external HDD connected as well to the Pi and it was struggling powering both, so I thought about powering the TB separately.
I read on a separate forum that I had to only stop Pin 1 on the Pi side because the ground (Pin 4) is still needed for the Pi to recognize that the DAC is connected.

I powered everything up and it looked ok, I started playing some music and still nothing strange, but after about 15 seconds I thought that it stopped playing because i couldn’t hear anything and the player was still running.
After getting very close to the speakers i realised that it was just the volume that went very low.
Basically Volumio recognizes the DAC, everything seems to work, but at 100% volume i now get what before was probably no more than 4%.
I tried reverting to a standard powering (standard USB into the Pi) but I still have the same issue.

I tried connecting the TB to my Ubuntu laptop and it seems to work normally with standard volume level.

Have you any suggestion on what could have happened?

P.S. when this happened, I had a ifi iPurifier3 between the TB and the Pi

I tried searching for a similar issue but couldn’t find anything, I hope this was not discussed earlier.
Thanks a lot for your help!

Giulio