V3 doesn’t recognize hifiberry digi+

Volumio Version: 3.174
Raspberry Pi 3 Model B with Hifiberry Digi+

After upgrading, Volumio doesn’t recognize my Digi+ soundcard. I downgraded to V2 and everything works fine.

please select you DAC by enabling I2C .

This doesn’t seem to work again, neither does work selecting the snd_hifiberry_digi from output list when it appears. I can’t get any sound out either from my Hifiberry Digi+, this was fine couple beta versions ago, seems to be broken again.

@volumio

Hi can you have a look here?

Hy, Volumio 3 (update from 2.917) works fine on my Raspberry 1 + Hifiberry DIGI.
Regards

Hello ! I had the same issue and this solved my issue :

  • Plug the SD card into a computer, and remove force_eeprom_read=0 from config.txt

Hope it works for you too !

3 Likes

Thanks, this one actually worked! Now finally running my Digi+ with Volumio 3

1 Like

Withuout this line removed, did it not work?
Did you select it from the I2S DAC list?

Correct, I had to comment out the force_eeprom_read=0 from config.txt to get it working. Without that I could select it from the I2S list, but I got no sound, and got little red squares with error messages from alsa when trying to play a track. Tried some of the other tricks like booting with a usb dac connected, but removing this line was the only one I got working.