[V2] 0.976 RPi B/RPi B+ System Not Booting/Responsive: FIX

Hi everyone, if you’re currently experiencing Volumio2 not working on your Raspberry Pi Model B, or B+, then you are likely running into an out of memory issue caused by processing background images.

In order to fix the problem, and regain a living old RPi + the new Volumio hotness, do the following:

  1. Connect RPi to display + keyboard (if you are able to SSH in at any time you can try that way, but I never was able to due to not being able to configure the WiFi interface)
  2. Boot, and as soon as possible after the boot (don’t wait or it will crash and you will have to reboot), log in as root/volumio
  3. Issue the following command: “systemctl stop volumio”
  4. Navigate to the following folder and delete all the existing .jpg’s: /volumio/app/plugins/miscllanea/appearance/backgrounds
  5. Run systemctl start volumio

Your Pi should now function properly. My tested config: RPi + HiFiberry DAC + Edimax Wifi

Thank you, worked for me as well!

Just corrected the path, there was a typo.


Cheers Christoph

As I don’t have a HDMI display could somebody provide a working image for download ?

comfirmes, erasing the backgrounds works fine.

I did the following and worked for me.
Use filezilla, login with volumio account and delete jpg files in


I followed the steps and it worked, but still the overall responsiveness of the system is not as good as v1.5.

Also, in the past I normally will use the WebUI and also an android apps to control the volumio. When I was using v1.5, the 2 sync well - whenever I do something in the apps, the WebUI automatically knew it, and vice-versa. But after using v2, the 2 do not sync, the WebUI does not recognize the actions I make with the android apps.

What are you running Volumio on?

The functions that control volumio are now standalone, which is why you cannot control them using an app. An interface between them will be added in the future to allow for control with android apps etc.

I am running a Raspberry Pi B+.

I did not use the volume control. When I said the apps and webUI did not sync, I am talking about when I add a song in the playlist using the app, it did not show up in the webUI.

Also lately I faced a stability issue, the system hangs from time to time. I have to switch back to v1.5 now. I am not sure why the system hang.

hey guys I can’t login via filezilla and delete the given folder. Can you give me an instruction how to delete the folder via terminal?
I tried:

rm -R /volumio/app/plugins/miscllanea/appearance/backgrounds

but got the message “no such a file or directory”.
Do you have any other recommendations?

There’s a typo there. Try this path: