V 3.251 - mounting USB drive problem

Prerequisites

Volumio Information

Volumio Version: 3.251
Hardware: ASUS Tinker Board
DAC: Internal

Debug Log

http://logs.volumio.org/volumio/Vmf8wxV.html

Steps to Reproduce

  1. Up-date from previous version

Additional Information

Automatic USB drive (EXT4) mounting doesn’t work. From dmesg I found:
[ 39.022135] EXT4-fs (sda1): Unrecognized mount option “iocharset=utf8” or missing value

Thanks for reporting.
Fixed with:Omit utf8 encoding from non fat or ntfs formats · volumio/volumio3-backend@4948274 · GitHub

This will be released in the next release, happening probably in around 10 days.

For now I just revert back to older release. I have back-up images made from working SD cards.

Feature sugestion for Volumio 4 - it doesn’t have to be in free version.

Make it possible to easily revert back to previous release if update doesn’t work. For example, premium users could undo current update and go back maybe one or two versions. I usually have working backup images handy, just in case.

Actually, we already have everything in place to make this happen. Thanks for the suggestion

1 Like

Downloaded the latest Test version (3.254):

Volumio recognize the USB HD and it’s content. (Thanks!)
(Despite the “standard” library problem of a lesser mounted/recognized albums)

Problem:
it restarts the Rasp every 2 minutes.

RPi4 (Version 1.5) 4GB - Hat DAC PecanPie

Hi Ornito,

I updated to v3.254 beta.
I cannot confirm rebooting every 2 minutes - mine is working fine.

br
Josef

Hi @Josh2000

I’m happy for you. :blush:
In my set up, it doesn’t work properly…
I’m going to wait for the stable and official release, when available.