V 2.773 Track selection

Fresh install of 2.773 on rpi 3b+

I have my Libary organsided A-Z then bands then albums containing the tracks… straight forward enough.
If I go to my music library, find a track from an album and tap it, Banner pops up say “Started playback of…” all seems good.

Then I go to the queue and its added the whole album not just the one track.
Also does this in the favorites. A big list of favorite tracks tap just one and it adds the whole lot to the queue.
Same with playlists, if I open a playlist to find a track I know is in there, tap on it to start playing, it also adds the whole playlist to the queue.
Also same with the search and as you can imagine that list could be very long. :slight_smile:

I tried this from both PC and Phone with the same results, can any one confirm this or do I have a bad install


Even more … it’s the same everywhere - album … artist … genre …

So it’s not a bug - but a feature :wink:

Yes, this is a change that many asked: to play continuously.
if you want to add only a single item, use the 3 dots :wink:

Hi @michelangelo and others

Sorry but I can’t see the logic to add a whole album to the queue when picking a single song !?
You have the play button on Album level to use.

BTW , the new interface/handling of artist and album is otherwise really nice :smiley:

Sorry, didn’t realize.
Imo, this way around makes it really unintuitive.
An accidental tap and you are spending the next few mins clearing tracks from the queue. At least before if you wanted to add the whole album, you had to do it deliberately and not by mistake.
Perhaps an option to have it either way, or would that be too difficult.
I’ll be sticking to the previous version for now.

Thanks for all the great work though :slight_smile:

okay now I understand ! :blush:
Left side play button works as usual
Tap or click right of the play button gives this feature

Is this really a desired feature ?
Can just see a lot of missclick frustrations and messed up playlists :laughing:

Thing is there is no left play button on the mobile version and when using a 5 inch screen tapping on the 3 dots at the side is hit and miss, so when you are selecting a track from a playlist of 100 or so tracks and it adds the lot by mistake you are certainly right, deffinatly not a desired feature.
Like the Volume control, a tiny bar pops up at the side with the +vol so close to the top of the slider bar its so easy to tap the top and hit 100% vol and blow your ear drums out.
Just seems the small screen mobile side of things are an after thought and not really tested for real world use.

If this is how its staying, it looks like I’m sticking with V2.729, but to be fair I only ever check out the newer version mainly to see if the “One click volume steps” have been sorted ( still broken a year or so later) and to see how the new UI is coming along. Shame

What do you mean with one click volume steps broken? It works. What is your setup and what does not work?

I have the same issue.

Using the android app, I don’t have the 3 dots on the right. I cannot choose to play one song. The entire cd is added to the que, then I have to delete the rest of the songs on the cd just to hear one song.

This issue almost makes Volumio unusable. It’s horrible. I’m failing to see how anyone thought this would be a good thing.

Can we please have a fix??


We have been requested this playback feature for long time.
I see that it creates discomfort for you. No problem, we can add a setting in playback option :wink:

I’ll try and be as detailed as possible any other info please ask.

I have an RPI 3B+ with a Topping D10 DAC connected via USB and set to use Hardware mixer ( obviously for best quality)
Volumio 2.729

Due to the small volume adjust bar, I have added a rotary encoder to hopefully control the volume a little more precisely.
This all works fine if I set the One Click Volume steps to 5, it goes from 0 to 100 in steps of 5 as you would expect.

The problem occurs when I set the One Click Volume steps to 1, it will start at 0 and count up to 14 thats all.
Its not the rotary encoder as I get the same result if I click the +vol icon, but you can slide the slider and that will adjust the volume to various levels as it should.
One Click Volume steps of 2, that goes to 58 before it stops

From playing around, it seems to work OK with mixer type set to software ( not ideal )
output device set to HDMI and mixer type set to Hardware also seems to work fine too
Problem occurs when Output device is set to USB and mixer type set to Hardware.

I even thought it was the DAC causing the issue, but I installed Moode yesterday, that seems to work fine with hardware mixer set and steps of 1 will count from 0 to 100 without issues.

What is causing it not to go above a certain level ?
Is there any way of making it go 0 to 100 in steps of 1 or 2 without having to set it to software mixer ?


Hi @M1ck and others

I didn’t check the mobile size window but you are correct !, can be a bit tricky to handle

A setting for this feature will be good :wink:

I have observed also me that I can not play a și gle song from qobuz, I need to play on album level…

The track selection which was always cumbersome since there was no way to select several tracks at once now ‘does not autohide’ after you select a track. One has to click outside the track list to make it ‘disappear’ in order to select another track.
In addition, for the last couple of versions the ‘progress bar’ only initially displays the correct time, later it seems to always restart at 0.

In ver 2.776 is this feature changeable by a setting in Playback options “Playback mode” , the default value is “Single” (in my case it was set to “single” after update)

Excellent :smiley: . I can easily select individual tracks again.
Although I did a clean install of V2.776 and the default setting was continuous. (not that it matters, as long as there is a setting to change between the two is what counts. Keeps every body happy then. )

One Click Volume steps is still broken though if you want 1 or 2 steps at a time.

Hm, I don’t see that option under 'Settings" > “Playback Options” and yes, I have 2.776 and “Full Settings Mode” enabled?

Where can i find v 2.776?

updates.volumio.org/pi/volumio/2 … pi.img.zip

This is a testing build?