Usbridge/volumio, different location problem

Hello, I have a problem using my usbridge with Volumio at different locations. If I have it set up on wifi and working great in one location fine but if I go to a different location with wifi or lan, it doesn’t work. How do I use my usbridge with Volumio at more that one location? My solution is to flash a seperate sd card and start over but I’d rather just use the same original sd card at 2 locations. What do you think? Thanks

It should work ok if Volumio is set to work with automatic IP on wired LANs (where there is an active DHCP server on each LAN). Wireless is a bit more complicated and will involve making changes from the console.

Hi chsims1, yes thanks, well I have that set so it should work. I’ll use the lan first. Does it help to have the hotspot fallback set to on? Also, so how would I do it with a wireless connection? I guess just have everything set to “on”. So far no luck, what say? Thanks

Hotspot is up to you … if you are likely to find yourself in a wifi situation, where Volumio doesn’t know the ssid and password, then have it as a fallback. If you are going between two places with different ssid/password, then you need to set up /etc/wpa_supplicant/wpa_supplicant.conf with the two wifi ssid/password combinations … the idea being if it can’t find one, it can find the other … have a Google if this is new to you.

Hi chsims1, well I had a google and it’s seems very complicated for my simple problem. Also I looked in the settings and there is no where to config the " /etc/wpa_supplicant/wpa_supplicant.conf ". I use Volumio in 2 places, one wired and on wifi. When I change places I can’t find my USBridge so I flashed another sd card to use. Weill now I have a 128gb card with tons of music on it and want to use it at both locations. I’ll keep beating on it until it works. Thanks for your help and knowlege, Richard

Oh well, that’s simple then (hint for future: give as much info as possible in the opening post. :wink: ) At the wired location with working Volumio, turn WiFi on under ‘Network’ settings, pick 'add a manual wifi connection with the appropriate security, ssid and password. Go to your second location and hopefully try it.

If that doesn’t work for some reason for the WiFi, look for the Volumio hotspot at your wireless location on your mobile/tablet, log onto the hotspot, and try adding your wireless network (this time Volumio should see the network, so don’t need to add manual connection).

Good luck, let us know how you get on.

gee wiz


i came around this by using the same SSID and password on more than 1 location, but i know this is only a way if you’re the admin on all locations.

Some - more professional - access points allow to configure a second SSID.


Hi Josef, yes thanks a lot. I have just kept everything “On” for both wifi and lan and it works. Very cool