USBridge and Chord Mojo: Randomly stops playing

I bought a new USBridge ten days ago.

My setup is USBridge with Volumio v2.282, Dual LLC PSU & Allo Wi-Fi Adapter -> Chord Mojo. Dual LLC PSU is connected to USBridge and the Allo 5V adapter is connected to Sparky. The Wi-Fi adapter is in the USB3 port (it does not work in the USB 2.0 ports). My files are stored in WD MyCloud.

The initial setup was a breeze. But, I haven’t had a smooth listening session to date.

USBridge would be playing just fine but would suddenly stop playing. I could not find a pattern to these random stops. Initially, for the first 3-4 sessions, it happened right after I tried to stream something from my laptop using Tuneblade. After disconnecting the device in Tuneblade, the stops would occur almost within 2-3 tracks. So, I switched to Stream What You Hear and HTTP Streaming.

But that was not the issue. Even when I played entirely from the NAS, playback stops randomly. There seems to be no set pattern to this. Sometimes, it happened after 6-7 tracks, sometimes once per album and rarely (like today), each track. Most times, I do not get an error message. The playing time counter would keep on increasing normally, but I would get no sound. The file type (320kps mp3, FLAC, 24/96, DSD) does not have any bearing on these sudden stops either. Most of the time, switching Chord Mojo off and on resolves the issue.

But, there are a few other times when I would get “Failed to open ALSA device. No such file” error message. When I go to playback settings during these instances, only “atm_7059 link” would be available. In Mixer settings, Mixer type is set to “Hardware”, but Mixer Control name combo box has no entries. When I click the combo, it sort of disappears (this happens irrespective of Mojo is working or not working). I have to power cycle USBridge and Mojo to play music in these instances.

I also have a Raspberry Pi3 running Volumio. Both USBridge and Pi3 are on the same table. The router, to which MyCloud is connected, is seated just about 2.5’ above these two. The Wi-Fi strength of Pi3 is shown as 72 Mbps and that of USBridge is shown to be 300 Mbps. I never had any issues with Pi3, be it playing through the same Mojo (or) streaming from my laptop. I don’t know why the issue occurs only in USBridge.

I also tried to increase the “Audio Buffer Size” to 12 MB and “Buffer before Play” to 20%, but it had no effect.

Today, I reset Volumio to factory settings. Did a fresh setup, but am still facing the same issues. I have had 4 random stops in just about a couple of hours.

I am a complete newbie when it comes to Linux, so I didn’t know how to debug or where to look for answers. Hopefully, this can be resolved in this forum and I can finally just listen to music soon :frowning:

waiting answser too ,my pi3 usb connnest to my dac also same problem like this !!!

just update latest ver ,problem still .cant open usb audio output,and alsa too

Ever since posting here, I have had two sessions - one on 25th and the other on 27th. During both sessions, I had the same issues. On 25th, it stopped thrice within 4 tracks but then ran fine for three complete albums - my first ever uninterrupted session with USBridge. On 27th, it stopped playing twice within the first album, once during the second and third albums, but I was able to complete an even longer session this time (6 albums in total, with the last interruption at the beginning of the third album).

I am still unable to figure out the reason for these frustrating interruptions. Whatever I do, they still seem to happen.

Another question: When playing files, FLACs play correctly at all bitrates. But, MP3 files show 24 bit / 44.1 khz. Why are they being converted to 24-bit?

I was hoping that the next update for Sparky would fix this. Hopefully, it doesn’t go the same way as your RPi :frowning:

I will forward this to Allo, I’m sure we’ll find a solution


there are still a few bugs on the OS , we are working to solve them. Will update everyone next week

Could you please send us logs just after this problem happens? It’s the only way me and Allo can understand what happens … oting.html

Hi Saifon

is the problem related to USbridge of RPI3 ?

Saifon, IMHO your is a different problem. Go to playback options, select your USB DAC and click save, let us know then

I do have some old logs.

Oct 16th: On this day, Allo Wi-Fi Adapter did not work on boot. I eventually solved it by moving it to USB3 port of Sparky. I did get the “ALSA: Failed to open device” error message.

Oct 22nd

I tried to send a log yesterday as soon as the problem occurred. It was “sending…”, but I did not get the final URL (possibly because I switched tabs in between?). So, not sure if it was successfully uploaded or not.

Whenever the random stop occurs next time, I will try and send another log.

Yes thanks. The first log tells that your DAC was not connected (or not identified) , while on the second I don’t see anything wrong

Please let us know

How do you power the USBridge ? Please make sure that you power it using the DC barrel not the micro USB.

I am using rpi3b, my English poor.i will try my best to explain.

Before got problem,I am use USB connect DAC audiogd nos 7 +rpi3 volumio 2.141 (and keep update ver still 2.246) everything is fine.

26october2017 change DAC audiogd r2r7, error fail open alsa hw 5.0 and can’t open audio output.and come here find answers.donwload new ver 2.296
27october 2017 flash new ver volumio 2.296.problem still same . I try change back my old DAC nos7 and oppo105d the problem is still there

flah back to ver 2.201 .problem still

I have problem with USBridge+Volumio too (DAC XiangSheng DAC-05).
When I start music, song play about 1-2min and stop, when i want start again is error:
Failed to open “alsa”, Error opening ALSA device “hw:1,0”; snd_pcm_hw_params() failed: input/output error.

I switched i2s dac on/off and restart and is the same (play 1 min. and error alsa)


It seems to be a problem from your Xmos USB. Can you check with manufacturer that it has the latest flash ?


your problem is not related to USBridge. Please open a new thread .

Sorry for the late reply. I power USBridge via Dual LLC PSU (5v) DC barrel and Sparky is powered through your bundled PSU.


Today was my first session since my last post here. The playback stopped again at the end of track #4 and this is today’s log. In the /dev/ page, the Seek value kept on increasing, even though there was no audio from Mojo. The playback stopped at the end of track #4, but in the /dev/ page, track #5 was ‘playing’ and it moved to track #6 as well. I switched off Mojo, switched on, went to the playback page and clicked the play/pause button and it started playing track #5 from the beginning.

Just after playing Track #5, playback stopped again (Another log). This time, Seek was not increasing in /dev/. I have re-started Mojo yet again.

You are powering it correctly .
Volumio os for Sparky is getting upgraded .

Can you try this new version (update with DEV updater or flash from scratch) ? …

And report if that solves your issue?