USB DAC works fine on Pi Zero W, but not on Pi 4B?

I wanted to upgrade from my Zero W to a 4B. Odd thing is the 4B doesn’t “see” my USB DAC, which works fine on the Zero W. (KGUSS K-3 - essentially an FX-Audio)

Tried just moving SD card to the new system first (Zero to 4), then I tried a clean install on a new SD card in the 4. It still doesn’t see the USB DAC on this hardware.

Moved original card back to the Zero, and DAC works fine there. Any thoughts?

Also noticed the 4B “lost” the external drive with the music after a reboot. Something with the USB ports on the 4B perhaps?

Did you try both USB3 and USB2 ports? Sometimes that does make a difference.

So…Get this. Tried all 4 USB ports, no dice. Just for the heck of it, plugged the hub the Zero was using to connect to the DAC and a USB Ethernet adapter…and the 4 sees the DAC now and works great.

No idea what the hub is doing to make it work, buuuuut… I’ll take it?

The only thing i can think of is a powered hub supplies power direct from the start but hey it works.

It’s a cheap little unpowered hub. Crazy, right?

Probably gives you usb 2.0 ports and that can make a difference.