USB Dac not working with Spotify Connect plugin

It took a good bit of troubleshooting to isolate it to this but I’m pretty confident that the problem stems from the USB Dac as a selected output. I see the latest build of Spotify Connect 0.9.3 has verbose logging but I’ll need someone to point out where I can find the logs.

Issue: No devices running Spotify (iPhone, Android, windows, osx ) are able to connect to the pi. They all see the device but time out when connecting. Zero successful connections made.

What works: iOS and OSX devices connect and play fine with Airplay using USB dac. Spotify Connect works when playback is switched to the audio jack on the pi. Other pi with Allo Boss works every time with every device when using Spotify Connect using most current version of plugin and volumio.

What I’ve tried: oodles of reboots, March and February releases of volumio, factory resetting, 0.9.1 and 0.9.3 Spotify plugin, multiple uninstall/reinstall of plugin, changing mixer from hardware to none, changing playback device to audio jack (only thing that worked).

Device Details:
pi 3+ running March 12 release of volumio and 0.9.3 of Spotify Connect.
Schiit Modi Multibit USB dac

Tracking this over at

I had this problem today - I have a Allo USBridge Signature with Allo Digione Signature as a hat. I was running the Digione to a Cambridge Audio DACMagic 100 and Spotify Connect worked fine while I2S Dac (Digione) was selected. I thought I’d try USB instead from USBridge to the CA and local files played fine. Spotify could see the unit on Connect but wouldn’t connect. Switched back to I2S dac and it was fine again… I’d really love to know why this might be because I was just about to upgrade the CA to an Allo Revolution which is USB only. Thanks in advance.

Could you share some logs?

Either from the /dev page using the livelog feature or via ssh.

# Volumio logs
journalctl -f
# vollibrespot logs
journalctl -f -o cat -u volspotconnect2.service

Note you might need sudo before these commands depending on the version of Volumio your running

I’d hazard a guess and say you might have something similar to

– Basically a misreported mixer, causing the daemon to crash.

Hi I’d hazard the same guess. I’ve reverted back to using the Digione Signature and that works fine. But I’m thinking of buying the Allo Revolution DAC which only works as a USB DAC. Do you know if there are any Spotify Connect issues with this DAC?

Well, if the DAC has an ALSA driver for the mixer, then it should work with VLS…
If not, you need to setup the software mixer.

Either way, I can’t tell you for certain unless I see the logs, without them I’m just making educated guesses :wink: