USB DAC not compatible?


New member here, also new to Volumio and raspberry pi’s.
I have an Earmen Donald DAC which I would like to use with my RPi 4B. This usb only dac works well on my Windows10 pc, and sounds great. However it is not recognised by the pi, I have tried with Volumio and other pi OS’s (RopieeeXL, Raspbian). Volumio looks great and is my preferred option.

Is there anything I can do about this, or have I bought the wrong dac? I am obviously wrong for assuming that it would just ‘work’ by being connected over usb. I have messaged the manufacturer, Auris Audio, but not received a response yet.

Some detail
DAC: 32 bit Cirrus Logic CS 43198

From Windows device manager, hardware ID:

Any help would be gratefully received.

1 Like

Here is the USB DAC compatibility list:

That Cirrus Logic CS 43198 doesn’t seem to be on it.

Yes thank you. I guess my question is whether I can find a solution somehow, with drivers, or should I start again with a dac which has proven compatibility.

Please excuse my lack of knowledge on how these work.

I have had a Donald DAC from before and have acquired RPi 4 just a few days ago. Guess I needed to look at the compatibility list before all this…
I presume there are no news regarding a Linux driver for this DAC?
NOTE: I have tried it with a PiCorePlayer as well, with the same result: no sound coming from the RPi. Maybe I am too inexperienced in his RPi business, maybe I don’t know how to properly set the Pi?

Hi, no I did not find out how to resolve this. I am guessing that the Donald DAC needs a driver to work on Linux. I do not know how to get one though. If anyone does please let me know.


I have contacted the manufacturer, EarMan, with the issue, but their answer was not really helpful. I am enclosing their answer in full here:
“Drivers have no connection with the DAC itself. It is the USB class 2.0 driver (audio class driver) that is needed.
Every OS requires such a driver., the only difference is that some systems already contain such a driver (WIN10, Android, iOS…), while others that don’t have it require installation of our driver (WIN7, etc…). Our driver doesn’t support Linux.
Newer Linux versions already contain that class of drivers, but we did not develop a specific Linux driver for our product.
The user needs to check if his/her Linux/RPi OS contains USB class 2.0 driver and if it is usable in this case”
So, unless someone knows how to install/activate the USB class 2.0 driver on Volumio, it seems we’ll be shopping around for another DAC, unfortunately.

One way would be to use a beta version based in buster to test. Please surch the forum.