USB DAC: No Sound

Running Volumio 1.4 on Raspberry pi, with a Muse Audio mini USB DAC (PCM2704-based), the DAC shows up as “DAC” and is selectable, but when I play no sound comes out. It works fine as a DAC connected to my Mac…Any suggestions? Here’s what aplay -l says:

root@volumio:/home/volumio# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: DAC [USB Audio DAC], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 8/8
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7

So I had this issue on Rune using an AudioQuest DragonFly and when I figured it out finally I accidentally blew my woofers :slight_smile: so make sure when your jacking with this you pay attention. Of course the foam was dry and brittle but I definitely blew it when I got volume working. Now having said that, I just flashed Volumio and seem to be having the same issue, but I need to test it in another stereo.

The fix was messing around with mpd.conf check the man page on the internet for more options.

This is what I have on the Rune working extremely well.
audio_output {

	 type 		"alsa"
	 name 		"DragonFly"
	 device 	"hw:0,0"
	 mixer_control 	"PCM"
	 mixer_device 	"hw:0"
	 mixer_index 	"0"
	 dsd_usb 	"yes"
	 replay_gain_handler	"none"

}

Actually that was the wrong config…here is what I have working and I edited it by hand not through UI since that defaults back to the templates

###################################

Auto generated mpd.conf file

please DO NOT edit it manually!

Use RuneUI MPD config section

###################################

follow_outside_symlinks “yes”
follow_inside_symlinks “yes”
db_file “/var/lib/mpd/mpd.db”
log_file “/var/log/runeaudio/mpd.log”
pid_file “/var/run/mpd/pid”
music_directory “/mnt/MPD”
playlist_directory “/var/lib/mpd/playlists”
state_file “/var/lib/mpd/mpdstate”
user “mpd”
bind_to_address “any”
port “6600”
log_level “default”
zeroconf_enabled “yes”
zeroconf_name “runeaudio”
volume_normalization “no”
audio_buffer_size “2048”
buffer_before_play “0%”
filesystem_charset “UTF-8”
id3v1_encoding “UTF-8”
gapless_mp3_playback “yes”
auto_update “no”
#mixer_type “disabled” none,hardware,software
mixer_type “disabled”
max_connections “20”

decoder {
plugin “ffmpeg”
enabled “no”
}

input {
plugin “curl”
}

audio_output {
enabled “yes”
type “alsa”
name “AudioQuest DragonFly”
device “hw:DragonFly”
#device “hw:0,0”
dsd_usb “yes”
mixer_control “PCM”
mixer_device “hw:0”
mixer_index “0”
replay_gain_handler “mixer”
}

audio_output {
enabled “no”
type “alsa”
device “hw:1,0”
name “AnalogJack/HDMI”

Ok, got it working in Volumio, has some clicks and junk that I need to figure out but overall its working as expected.

root@volumio:/etc# cat mpd.conf
###################################

Auto generated mpd.conf file

please DO NOT edit it manually!

Use player-UI MPD config section

###################################

follow_outside_symlinks “yes”
follow_inside_symlinks “yes”
db_file “/var/lib/mpd/tag_cache”
sticker_file “/var/lib/mpd/sticker.sql”
log_file “/var/log/mpd/mpd.log”
pid_file “/var/run/mpd/pid”
music_directory “/var/lib/mpd/music”
playlist_directory “/var/lib/mpd/playlists”
state_file “/var/lib/mpd/state”
user “mpd”
bind_to_address “any”
port “6600”
zeroconf_enabled “yes”
zeroconf_name “volumio”
samplerate_converter “Fastest Sinc Interpolator”
volume_normalization “no”
audio_buffer_size “4096”
buffer_before_play “20%”
filesystem_charset “UTF-8”
id3v1_encoding “UTF-8”
gapless_mp3_playback “yes”
auto_update “no”
mixer_type “disabled”
group “audio”
max_connections “20”

decoder {
plugin “ffmpeg”
enabled “no”
}

input {
plugin “curl”
}

audio_output {
enabled “yes”
type “alsa”
name “AudioQuest DragonFly”
device “hw:DragonFly”
#device “hw:0,0”
dsd_usb “yes”
mixer_type “hardware”
mixer_control “PCM”
#mixer_device “hw:0”
mixer_device “hw:DragonFly”
mixer_index “0”
replay_gain_handler “mixer”
}

audio_output {
enabled “no”
type “alsa”
device “hw:1,0”
name “AnalogJack/HDMI”
}

Thanks, that worked!

I investigated a bit more, going back to what volumio writes into mpd.conf, and then adding:
enabled “yes”
to it, plus I changed the name to “muse”, followed by the same section you had for the built-in audio, including enabled “no”. That’s working also, so I think there was a problem with it deciding that the built-in audio was the one to use, even though it wasn’t specified in mpd.conf (or at least that’s my guess). Maybe after I get tired of listening to music I’ll take out the section for the built-in audio and see if it still works with just the enabled “yes” added…

Sweet glad you could get it working.

I seem to be having a similar problem. I have a PCM 2704 DAC and can get no sound out of it in version 1.4 (it worked fine with 1.2). I have tried making similar edits to mpd.conf to those posted above, but no luck so far. The audio out jack on the pi works fine when I choose ALSA as the playback option. Can anyone suggest how I might get this to work?

I have a similar issue with my ARCAM rDac.

Please let me know how to modify mpd.conf to make it to work. Please see the outcome of aplay -l:

card 0: DAC [ARCAM DAC], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: ALSA [bcm2835 ALSA], device 0: bcm2835 ALSA [bcm2835 ALSA]
Subdevices: 8/8
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
Subdevice #4: subdevice #4
Subdevice #5: subdevice #5
Subdevice #6: subdevice #6
Subdevice #7: subdevice #7

your dac is device 0 so you can use the hw:0,0 line or edit what I have to match your device name which in your case is DAC

thats all I can suggest, other than staring at the man page for mpd.conf like I did forever :slight_smile:

Same DAC same problem as Dsnny. Have tried scripts above but no joy. Volumio shows streamed music being played, but no sound. DAC recognised OK at boot. Guess I may end up going back to OPENELEC but I wanted to compare with Volumio. If anybody gets there please post

I got this working by just switching back and forth between the Dragonfly and the ALSA output. Also to note is that the volume inside volumio when I switched to my DragonFly was set to almost zero. This is actually a good safety feature, as it would probably have killed my speakers had it started to play on full volume from the start.

Buy Amitriptyline Online Uk canadian cialis Get Legally Clobetasol Best Website Overseas Pharmacy Cialis Keflex Diarrhea