Update to 2.185 not working


I’m trying to update volumio from 2.118 to 2.185, as the update is available in system options. On launch, it goes for a backup, finally said 2.185 has been successfully installed and ask for a reboot.
After reboot my system is always running on 2.118 and update is still proposed. I’ve tried it three times with the same issue, I’m in an infinite loop. Could someone tell me what’s going wrong please ?
I’m on Rpi3 with hifiberry dac +.

  • Which version did you flash originally?
  • When you reboot, which menus do you see in my music?


I had flashed the first release of Volumio 2 and until the last one (2.185), all the updates have always been well applied.
In “my music” I got 3 rubs : “my music”, “network drives”, “Album art settings”.

So am I really the only one in that case ? Is there something I can do to force update apart flash the whole thing again and loose my prefs ?

You would be advised to flash a fresh version. You could manually save your preferences by archiving the contents of ‘/data’ if you have access to the command line.

frnckdsrt you’re not alone. I have the same setup and same problem.

EDIT: OK, now I tried again to update and it seem that it broke my Volumio installation. Can’t connect to volumio.local or IP neither LAN or wifi is working. Weirdly enough I can still access an USB disk that is connected to the RPI?

This is an issue related to not enouogh space in the partition where we store images. Unfortunately the only way is to reflash from zero. We will have a data backup\restore in the future…

Ah. OK, edited my post as you were answering, michelangelo. I guess I need to reflash anyway as it is now…

Thank you people for advice and explanation.

Had the same issue here, will reflash. @michelangelo, which partition is required to be enlarged? Is there a minspec for SD Card size?