Update not working

Hi, I am trying to update the newest version - and it does not react at all.
The update-version before started - but then it stopped. there was an information that I should wait for the next update - but this one (2.141) doesn’t even react when I try to activate the button to start the update.

What can I do???

Please restart your device and try again. Keep me posted

From changelog on changelog-t1575.html I can’t see the new additions for 2.141.

For instance addition for Digi+ Pro??

Well - I did just that and restarted it.

Then it started working and said “Creating backup”, but stopped at 20% for a while.
Then the message “update successful” came and that the system had to be restarted. But - after the restart nothing happened and I am still working with version 2.114 from 2nd March.

What can I do now?

I think something has definetely gone wrong there.
From which version were you starting (the first version you flashed)

Oh - I don’t remember. Must have been the first version of volumio 2. Sometime back in November 2016.
The version that’s running now is, as I said, 2.114 from 2nd March. That was the second update - until then everything worked fine.

I can post a separate topic but I am having a similar issue updating. I have two separate volumio instances and neither one says they are running 2.141 even though it said the update is complete and I need to restart (which I did). When it boot back up, the version reported is still the previous version.

One of them is running version 2.129 and the other is running 2.118 with a Hifiberry DAC plus. The one running 2.118 takes over 5 minutes before the web interface is available again after the reboot.

I tried to ssh into them to see of the logs show anyting but I can’t ssh into either one. It put in the credentials and the ssh connection immediately closes after I type in the password.

Ok. I think I got what has gone wrong. Thanks for the info.
Unfortunately for you, the best thing to do will be reflashing your SD Card with the latest version

We are looking into this to provide an effective fix!

Same here. On 2.118. Update shows me 2.141 is available, downloads it, reboots, no change. Can’t ssh in either now (just disconnects).

Will you fix in a way which should let us update in future? (I’m being lazy and don’t want to unhook it all and reflash :slight_smile: ). Quite happy to wait!

Same for me :astonished:
I’m running a raspberry pi3 with Kali & piano 2.1.
Current version is v2.118 and it says update v2.141 available. When I start update it stucks at 20%. One or two times it ran through and said update successful / reboot, but after the reboot it’s still version v2.118.
I would appreciate if there will be another solution rather than to reinstall completely. Or if that’s not likely or possible, that there will be an information accordingly.
Many thx, Axel

Same for me too. I’m on 2.114 and tries to upgrade to 2.141. The upgrade seems to be successful and I’m asked to reboot. After rebooting the Pi is still on 2.114. Have tried twice with same result.

I am really sorry about this, but there is only one way to fix it:

  • Before doing the update, do a delete user data (from system).
    You will loose all your playlists, settings etct, but from now on you will be able to update without issues.

Maybe it is a stupid question, but I didn’t find response neither in the FAQ nor in the web UI: is there any manual way to backup & restore all user data (just in case…)?

Did as instructed. Unfortunately the Pi got completely unresponsive after the reset. I’m reflashing now …

Similar here. Cleared user data and restarted and it disappeared off the network completely. I’m guessing this also nuked the wifi details. The hotspot didn’t re appear. Wacking a monitor into the HDMI showed me that that wifi was coming up but on a 192.168.211.x network (no idea why) which I can’t see from 192.168.1.x network (I’m guessing with a network tweak I could, but I don’t know what to add). Plugin in an ethernet cable didn’t bring anything up. There were errors for DHCP and something relating to IP4LL? (it zoomed passed quick, not sure how to find that log).

I’m just reflashing…

(edit: I think the 211.x was the hotspot but my laptop refused to see it!)

Well, I deleted all the user data - and now everything works fine again,
Thanks for the help!


I tried to update to the latest version today. Same procedure again - the update stops at 20 %, then restarts the system and stucks where it was before.

I thought everything was fixed… :frowning:

Tried again on v2.175. Update failed identically.

Well, I did it all again - cut off the raspi from the wireless and connected it via lan. Then deleted all the user data, updated to the latest version and connected it again to the wireless lan. Everything seems to work fine again now.

I definitely do hope, that this is not going to be a habit - losing all my settings and then start from the beginning again.

I am really sorry to post all this, because - aside from that trouble - I am totally convinced by volumio and your great work. But this is definitely a nuisance…

Hi, my update is not working either.

I’m using System Version: 2.201 Released: Tue Jun 13 21:31:16 CEST 2017

This is shown in my log

2017-08-05T18:46:48.190Z - info: Sending updateCheck to server
2017-08-05T18:46:48.743Z - info: Update Check error: [object Object]

Is there a way to

  • get more debug info?
  • fix this without flashing the newest volumio version?
  • make the version code copyable in the web ui (or a button to copy it to the clipboard)? :laughing:

Thanks a lot :wink: