Update from 2.118 to 2.201 doesn't work

I’m using a PI3 with Allo’s Kali and Piano 2.1, currently on version 2.118. When I click check updates the version 2.201 is offered. By clicking update the update stars and after while it says update successfully, please reboot. But after reboot the version 2.118 states again.
Is there anyone who had the same problem respectively somebody who knows how to overcome this?

I’m having exactly the same issue. I have tried many times but after restarting it seems to be kept at 2.118.

I’m wondering if it’s only us two having this problem?

io ho un problema diverso quando ho aggiornato non mi legge piu’ hard disc bo mi sa che devo passare a rune visto che volumio da tutti sti problemi

Not an answer for why you are having the problem, but why not simply flash a new disk image? It’s the quickest solution, especially now that there is a data backup plugin available (note that this is a beta plugin, but it has worked fine for me).

Hi Chsims1 could you explain me how it works and what’s the procedure what i have to do i do not know thanks

I assume that you mean the data backup plugin & not how to flash an sd card (volumio.org/get-started).

Install the plugin & in settings choose what you want to backup (you can archive all user data, or just playlists for example). This archive file (volumio_data.tgz) is saved to the samba share ‘Internal Storage’ & you should copy this file to your local PC/Mac/whatever. Flash the new Volumio image & boot up. Copy the archive file back to the Samba share, reinstall the backup plugin, restore your data & reboot. It all should be back to working order :slight_smile: (You will still need to reinstall other plugins that you had & also rescan your music collection).

I like to use the update functionality exactly in order to avoid the hassle you describe. AlsoI think that’s why the update feature has been implemented.
Independent from this the workaround with this backup plugin isn’t available for me (it’s not offered in the plugin list (?))