[Unsupported] Volumio with pulseaudio and pulseeffects - 0 cards visible

Volumio Version: 3 beta 2021-5-17
Hardware: RPI4 2GB
DAC:HiFiberry DAC2

Hello everybody,

for several days iam trying to make pulseaudio working on latest Volumio beta 3 but iam having difficulties with pulseaudio - i installed it fine as well as pulseeffects but pulseaudio dont see any cards that are connected to system therefore pulseeffects is not working as well. pacmd command is saying that there are 0 cards and no ALSA sinks as well. I tried to add myself to audio group and pulse and pulse access group but still no luck. I tried a lot of advices on different forums about debian, raspbian and pulseaudio but iam starting to believe that this condition happened because of certain specific configuration of volumio. Maybe volumio is actively preventing other software to connect to sound card or something similar.

Aplay -l results

**** List of PLAYBACK Hardware Devices ****
card 0: b1 [bcm2835 HDMI 1], device 0: bcm2835 HDMI 1 [bcm2835 HDMI 1]
Subdevices: 4/4
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
card 1: Headphones [bcm2835 Headphones], device 0: bcm2835 Headphones [bcm2835 Headphones]
Subdevices: 4/4
Subdevice #0: subdevice #0
Subdevice #1: subdevice #1
Subdevice #2: subdevice #2
Subdevice #3: subdevice #3
card 2: sndrpihifiberry [snd_rpi_hifiberry_dacplus], device 0: HiFiBerry DAC+ Pro HiFi pcm512x-hifi-0 [HiFiBerry DAC+ Pro HiFi pcm512x-hifi-0]
Subdevices: 1/1
Subdevice #0: subdevice #0

pacmd list-cards

0 card(s) available.

    pacmd list-sinks

    1 sink(s) available.

    * index: 0
    driver: <module-null-sink.c>
    state: IDLE
    suspend cause: (none)
    priority: 1000
    volume: front-left: 65536 / 100% / 0.00 dB, front-right: 65536 / 100% / 0.00 dB
    balance 0.00
    base volume: 65536 / 100% / 0.00 dB
    volume steps: 65537
    muted: no
    current latency: 141.41 ms
    max request: 344 KiB
    max rewind: 344 KiB
    monitor source: 0
    sample spec: s16le 2ch 44100Hz
    channel map: front-left,front-right
    used by: 0
    linked by: 0
    configured latency: 2000.00 ms; range is 0.50 … 2000.00 ms
    module: 3
    device.description = “Null Output”
    device.class = “abstract”
    device.icon_name = “audio-card”

Iam not sure why it is like that, iam running it headlessly i read somewhere that i need to login to startx or something, not sure

i tried to start pulseaudio with --system argument but no luck

Is anything what could cause pacmd not see any cards crossing your mind? Please let me know, iam lost in this for days already and pretty desperate. Thank you guys

OK so i uninstalled and installed pulseaudio and pulseeffects and now its listing cards correctly but it doesnt detect any input sinks? Anybody knows why that could be?

did you check “sudo journalctl -p 7” (or dmesg) for any specific errors?
Few of us are experienced with pulseaudio, would it not help to set it up on a bare headless raspbian machine first and try the raspbian forums for any help with pulseaudio?

1 Like

On bare headless raspbian buster iam able to see input sinks without any issues. There is also zero in there but once i start playing something in vlc etc it appears in pacmd. But its not happening with volumio, when i start playing anything on volumio pacmd still sees 0 input sinks. But i have several SD cards with full setup on normal raspbian with gui, fully working. I am passionate about volumio for many years, i even had skype call with Michelangelo about my speaker years ago. Iam very close from finally finishing it last thing i need is pulse audio (pulseeffects) working, for that i really only need to be able to see that volumio stream (input sink). Maybe its because of group membership somehow? I dont see any specific errors anywhere.

I just checked the build logs for RPi, it seems (parts of) pulseaudio is already installed as dependencies of the bluetooth plugin,
this is the link to the 3.074 log
You may want to check this and search for “libwebrtc-audio-processing1 linux-libc-dev manpages manpages-dev pulseaudio
pulseaudio-module-bluetooth pulseaudio-utils python-gi python-gobject”


That is interesting thank you. But i am not sure how this can help me with input sinks not showing in pacmd :confused: