Unable to Update OTA

For a very long time now, I have not been able to update using OTA in Volumio. I have a MyVolumio Virtuoso subscription.

I had difficulties with a Raspberry Pi 3 but acknowledge that I was editing the config.txt file, so I thought no further about it.

Now I have an Asus Tinker Board S and perform no customisations. I am on v2.657 and I can Check Updates and it tells me that v2.671 is available. I let it update and after it has restarted I am still on v2.657.

Volumio simply never updates successfully OTA for me. I always have to re-burn the image to SD card, meaning I lose all my settings.

The only thing in common here is my MyVolumio subscription. Could there be something there stopping it from working properly?

Please would someone from Volumio respond? I’m a paying customer and it’s hugely irritating have to burn a fresh image to SD card every time.

What file can I check to verify if the update has been done, but maybe the subsequent version reporting is incorrect?

I would take a look at your network settings or network situation in general.

If you can never update OTA, even after flashing a new image and changing hardware then something’s up. Your network is the common denominator.

I have never had a problem updating OTA and it doesn’t look like there’s anyone else reporting such issues. The fact that you’ve had the problem so long suggests it’s something else as well. If it was a bug, others would have experienced and reported it already.

What happens exactly when you click check for updates?

Everything seems fine. The new version is offered, I click update. The update proceeds and then it tells me I was successful and tells me to restart. When I restart and check the version, it’s still on the old version. At no time is an error given.

This has always been exactly my experience: never a single OTA update successful in about one year of Volumio use. Everything seems fine, but after the automatic reboot, the version number is still the same. I’ve also tried once to restart from scratch by flashing anew the card with my current version, join my wi-fi network and go straight to update, to no avail.
Enabling ssh console and launching a ‘top’ while an update is going on, I’ve seen that rsync is actually used. So should a network error be responsible for the failure, the procedure might be able to catch an error and notify the user.

It’s good to know I’m not alone. Last night I tried using OpenDNS settings on my router in case it was down to BT Mobile DNS. No different, it all proceeds ‘successfully’ until I check the version after restart.

Sent from my LG-M700 using Tapatalk

Have you guys tried using a different web browser? Clearing cache etc?

I use the Volumio Android app.

I know of another chap who has this now.

We really could do with some advice or a way of logging what is happening.

This is a bit of an odd situation, tinkerboard is fairly widely used, also in our Primo.
If it would be a general problem, we would have had many more reports by now, as someone already correctly noted.

Do you all have the same issue with the same device, being a tinkerboard or a tinkerboard s?
Anyone with a Volumio Primo?
Are you booting from SD or eMMC (in case of tinker s and Primo)?
In case of eMMC, how and which version did you flash as the original software version?
Any manual changes to boot files?

As OTA did not work, did you reflash a newer version, and with that version the next OTA update again did not work?

Logging is not so easy, the process is a little complicated, but there are things that can be done and would be helpful to get us nearer to the source of the problem.
Does anyone of you know how to use a serial console to follow the boot process? And is able to record a log?
My contribution would be to create an extra version, so the update process can be repeated a couple of times (using factory reset).

But, even without a serial console, we can still do something, we need to stop the reboots, without a console it is a little trickier to get the right moment.

Thank you for your response. I’ll try and answer as best I can.

The problem is not just with the Tinker Board S, it happened before with a Raspberry Pi 3.

Booting from SD card, always. Two different high speed SD cards tried.

No manual changes to boot files made in recent times. I have been careful to make only Volumio setting changes. It’s not the DAC selection either, I used to use I2S and now I use USB.

When OTA update doesn’t work, I am continuously offered the same update and it always shows ‘Success’. It just never updates. I then reflash the SD card and the problem is solved except that I have to rebuild my settings. The next time an update appears, I have the same problem again. I use MyVolumio Virtuoso with Qobuz, Spotify and YouTube streaming services. No NAS.

I use a 60Mbps BT Mobile service via a TP Link 4G router. Ethernet cable into the Tinker Board S. I have tried both BT and OpenDNS DNS settings.

Do you have a known file which we can check for date/time against version number to verify if they are being replaced by the OTA process? As I said previously, it may only be the version number which is being misreported.

Thank you for any help you can give us.

You said you use the Volumio android app.

Can you use a desktop/laptop with a standard web browser and try to update.

If that works then you’ve highlighted the problem straight away, the android app.

The problem with the issue you are reporting is that you have already told us that is happens even with a fresh new image, and on multiple bits of hardware. Hardly anyone else is experiencing the same issue so this points to something specific to your environment.

I suspect its a web interface/browser issue at this point. Try on a proper PC using google chrome and report back!

I have used a browser previously but cannot remember if I ever invoked the update from a browser.

I will try it tonight.

This is what I’ve also tried, a couple versions ago: after an unsuccessful attempt to OTA, I still had my current version’s .img file so I reflashed the card with this same version (i.e. one version older than the proposed update), followed the normal startup procedure until I joined my wi-fi network (i.e. a very vanilla installation!), went to system > version check and launched the OTA, but as usual the system made a backup, downloaded the update (I always see network activity during the progress bar time), said ‘everything OK’, rebooted and the old version was still there.

I have a RPI 3B+ an 16Gb SD card and an HifiBerry DAC+ pro. I am a Volumio Virtuoso subscriber, but the OTA has always failed since I was on the free plan.

just for the record, I use most of the time the iOS Volumio app, but I tried OTA also with Safari and Aloha Browser on iOS and Chrome and Firefox Focus on Android.

This is very strange. I have a similar set up to you.

I use a Pi 3B+ with a 32GB SD card and a HifiBerry Digi+ Pro. I have never had a single problem using OTA update and I have been using Volumio for about a year. Also a My Volumio subscriber.

You havn’t tried a proper desktop mode browser however. On a PC or laptop. Not a mobile device.

  1. Maybe youve stumbled across a strange bug with a particular make/model/size of SD card.
  2. Maybe it something network related. Particular ISP, Wifi access point etc…

The big issue with this is that if it was a serious bug, then many many more people would be reporting it. So I am confident its something very specific.

That would be me, then.
I’ve just updated to v2.673.
Volumio reported success.
Volumio tells me I’m on the latest version when I check for updates.
Volumio still shows my version number to be 2.671.

The update was performed on a PC.

How bigs your SD card? 16GB? 32GB?

Im on a 32GB card and I have never had a single OTA issue. Other person above has a 16gb card.

Mine is a 16GB card. I would hope that we would have been told if a larger one is required?

I’ve tried the update twice now in Chrome. No change to the version number.

I didn’t think it could be the browser, after all the Volumio app is just a wrapper for the GUI.