Unable to add/modify/remove mounts using webui

Hi there,
I performed a firmware update and installed lirc, now the ‘library’ section of the webui is entirely unresponsive; the mount is now not valid (RED X next to mount in library view), and when I select ‘remove this mount’ the library page loads and the mount is not removed. I have looked at the fstab file in /etc but the syntax there is not obvious, so I’ve left it alone.
I consider the following problem secondary, but possibly related:
The PI is currently connected using a wireless network adaptor, however, the ‘network’ section of the webui does not indicate this - Instead the SSID and password fields are blank (as if never edited) and updating with the credentials and submitting results in the ‘system’ page being loaded, no changes to the network fields.
My first priority is getting the mount back, obviously, because my speakers are too quiet!
Truly perplexing situation…


I have a similar problem. Just installed Volumio on a BBB and driving an USB DAC. It worked nicely via airplay and playing an itunes library on my Macbook. I tried to add a music library on my brand new QNAP NAS, but the webui locks with the “connecting” message on the screen.
I can make new connection to volumio.local via web browser but I cannot remove the library mount point, neither connect to system or network and so on: the browser screen always locks with the “connecting” message. I can only play a webradio now.
By the way I can connect to volumio root user via ssh, but I do not know how to restore the default Volumio configuration. I am going to do it for the tird time by flashing again the microSD!

Any advice?

Thank you


To be honest I bailed. It was the xth time I’d tried to get everything working, but the whole process just seemed very…fragile. I don’t know whether setting the mountpoint alone will work, so I can’t say that using ssh to mount will be a particularly easy solution. You can mount the remote drive to /mnt and create a symlink between there and /lib/music which is where MPC will work from, but I’d say getting to the root cause of the webui breaking like that is more important…and for that, I have no answer!
Best of luck


One guess: there is no NAS directory in /mnt. Creat it, chmod 777 it and try again. :wink:

The /mnt/NAS is there. The problem is that now I am afraid to make any attempt because I do not want to flash the microSD of my BBB for the fourth time (the only way now I know to reset volumio).
I suspect the problem of my mount library failure is the proper NFS or SMB NAS setting or a wrong file path, but before trying
I would like to find a way to recover the proper operation of volumio webui when it locks. Any idea on how to reset Volumio to just out of the box installation?


If you truly want out of the box settings, by far the best way to go about that is to write the vanilla image to the card again. Can you do that?

If you mean flash again the microSD I already did three times!

Now I do not know if to try or not a new mount of the library. maybe tomorrow!


I could not wait and I was rewarded (at least my problem was solved). I simply added one more directory to the NFS mount point and I could mount my NAS file system in volumio!

However I cannot tell how to unlock volumio webui because it did not lock anymore.


After Add mount point, volumio is crashed :blush:

background worker is busy.

I’m going to explain how I several time reset a corrupted Volumio…
But it’s very “crappy” and this just something I have done, try it at your own risk…
So, all the config of Volumio is stored in a database, in the file /var/www/db/player.db
The idea is to remove wrong entries from this file (and setting the good value).
First, from my computer Ubuntu, I get the file from the PI.

sudo scp pi@192.xxx.x.xx:/var/www/db/player.db /home/user
[/code] Of course, remplace with your IP and home folder.
Then open the file with a tool such as sqlitebrowser [url]http://sqlitebrowser.org/[/url]
Go the browse data tab and select cfg_source. Modify or delete what you want, and save the table.
Now you have to send it back to Volumio : [code]
sudo scp /home/user/player.db pi@192.xxx.x.xxx:/var/www/db

Reboot (not sure it’s mandatory). And it should be ok :exclamation: :sunglasses:
I you are no afraid by the command line you can do directly by using sqlite3 command, but I can’t help you… :wink:
But this is the last trick before reflashing…

THANK YOU!!! :laughing: :laughing: :laughing:
Its help

Thank you :smiley: :laughing: :laughing: :smiley:

Thank’s :smiley:

That worked like a charm !!

I copied the player.db file to the USB Music folder and edited it from there. Then copied it back to its original location

Here’s a step by step guide (hope I didn’t forget anything :wink:

Open a terminal or console (on Mac search for the app “Terminal.app”)

From within the terminal app

Log on to your volumio installation

ssh root@volumio.local
if “volumio.local” doesn’t work, replace “volumio.local” with the IP address of your Volumio player or replace “volumio” with the name you gave your player it in the “system” section of the Web GUI, i.e. “my-volumio-player.local”.

default password is “volumio”

Go to the shared USB folder (directory)

cd /mnt/USB

copy the player.db file to here

cp /var/www/db/player.db .

(dont’t forget the dot at the end of the command [. = current folder])

Now the player.db file is in the shared USB folder directly accessible from your computer.

Get the sqlitebrowser app from here (thank’s for making it available for free !!)


Download and install it on your computer

Open the sqlitebrowser.app

From within the sqlitebrowser.app open the player.db file located in the USB folder which can be found in your network places.

Open the player.db file

Make your changes

Write your changes

Go back to the “terminal”

Rename the original player.db file to something else i.e. player.db.original

mv /var/www/db/player.db player.db.original
Copy the modified player.db file back to its correct location

cp /mnt/USB/player.db /var/www/db/player.db
Reboot volumio

reboot -f

Very good idea to use the USB location.

Another possibility is to use filezilla (ftp client) for download the db file to desktop. Modify and upload to the original location.

Bit of an old topic but managed to find a way to do this via the command line.

$sudo apt-get install sqlite3 $sqlite3 /var/www/db/player.db
You then get the sqlite3 prompt. Check we got the right database.

[code]sqlite> .databases
seq name file

0 main /var/www/db/player.db

List the tables

sqlite> .tables cfg_engine cfg_lan cfg_mpd cfg_source cfg_wifisec updates

Turn headers on and view the cfg_source table. Don’t forget the semi-colon at the end!

sqlite> .headers on
sqlite> select * from cfg_source;
1|Shared|cifs|192.168.*.*|share/transfer/Music|user|password|utf8|8048|8096|ro,dir_mode=0777,file_mode=0777, sec=ntlm|mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Find the entry with the error! I only had one entry so I could have just deleted every entry but you can specify the one you need to get rid of by using the id number.

sqlite> delete from cfg_source where id=1;

As soon as I did this I heard the lovely sound of volumio completing its boot sequence and getting unstuck.

Finish with

sqlite> .quit $exit

Here’s what I did, and it worked

  1. ssh yourvolumiopi

  2. sudo umount /mnt/NAS/nameofstickymount

  3. Go to web UI and remove mount.

  4. Reboot the device.

  5. Add a new mount