Two Volumio, One Source, Different Track Counts

Hi Everyone. Forgive me if I am repeating an issue; I DID try to avoid a duplicate post.

So, as the title states, I have two Volumio-enabled HiFi-berries that point to the same, single source of my MP3s, yet “Rescan” results in two different Artists/Albums/Tracks/Playtime counts.

Both Volumio are up-to-date in software version. One Volumio is a standard HiFi-berry and the other is the digital-output HiFi-berry.

When I log into the source of my MP3s (Synology NAS ds213j) and dive into the path my Volumio see, I ran a “find” and piped it to word-count to get: 9522

find ./ -type f -name "*.mp3" | wc -l

I even ran the same command in a Cygwin shell on my PC to look at the file share path just as the Volumio-berries see the path:

find \\\\\\music\\MyMusic -type f -name "*.mp3" | wc -l

Yet, here are my Volumio counts:

Maybe you can tell me where on each Volumio device the file that contains the full list of what it reads in is stored and I can pull both files to my PC to compare them? Or, a quick fix to this issue?


Are both the Volumio devices running the same version? (Volumio/mdp)

Yes - per my original post

UPDATE: I deleted my source on both devices and re-introduced the source all over again. NOW both units report 874 Artists, 1437 Albums, 9560 Tracks and 788:57:14 Playtime.

Not sure what go into the DigiBerry/Volumio, but that is the one I’ll keep a close eye on.


Can you share information about the two devices?

cat /etc/os-release
mpd --version 

EDIT: glad you solved it, happy holidays :slight_smile:

1 Like

would the details from what you asked still help? or, do we chalk this up to solar flares?

btw, I got the details you asked into two separate files and compared them with CSDiff.
absolutely no differences between the two for their os-release file contents and the mpd command.

Or probably just gremlins in the network :wink: