Trouble mounting network drive - TP-Link Archer router

I had a perfectly good volumio setup, been working for a year.
Today I spotted that I was a version or two behind so did an update from 2? to 3.176.
I read it would lose my wi-fi settings, no problem, but I hadn’t realised it would lose the details for my source drive and now I can’t mount it again.
I have a USB drive plugged into the TP-Link Archer router.
It’s shared out and all my Windows machines can access it.
The router settings page says:
Network/Media Server Name: archermusic
Access Address: \archermusic
Folder Name: volume(sda1)
Folder Path: G:
Volume Name: sda1

In Windows Explorer I use \archermusic\volume(sda1)
in the address bar and can see everything.

What I can’t work out is what I put in the various boxes and where do I need forward or reverse slashes etc. I’ve tried to read up on cifs and nfs but it may as well be in a foreign language.
I obviously did it once but stupidly didn’t document it.

For Alias I assumed is just for my use, I’ve called it bob
For NAS IP Address I used the address of the router
For Path I have used all combinations of archermusic, sda1, volume, volume(sda1), with and without forward and reverse single or double slashes
For File Share Type I have used both cifs and nfs
I’ve tried with and without the username and password of the router admin account
For options I have tried vers=1.0, vers=2.0 and vers=3.0

That was an awful lot of permutations so can’t be absolutely sure I didn’t miss one.
If I understood the difference between sharename, folder name and folder path in this context it might help. There are so many other people asking so I’m not alone, but I couldn’t distil an answer from them.

Another thought… the router help page states that the USB drive can be shared as a Media Server, I enabled that and since it says it “allows users on your network to play music on your shared USB storage device from DLNA-supported devices” shouldn’t Volumio be able to scan it?
If I enter http://192.168.1.254:8200 it returns “MiniDLNA status – Media library audio files 5682”
Can I point Volumio to this?

The problem here is knowing exactly how the path of the shared name appears to your Volumio device. Routers with attached usb drives seem particularly troublesome for some reason. If you can access the CLI on your device (is it a RPi?), then you might try “smbclient -L IPaddress_of _router” and see what shares it shows.

How to enable and use ssh.

P.S. I seen a few comments about accessing DLNA servers recently, but haven’t looked myself.

Edit. Might need to make that “sudo smbclient -L IPaddress”

IT WORKED so many thanks!!!

Thanks chsims1, what a great suggestion.
I got this and tried again using volume(sda1) and it worked :slight_smile:

Sharename       Type      Comment
---------       ----      -------
volume(sda1)    Disk
IPC$            IPC       IPC Service (archermusic)
Reconnecting with SMB1 for workgroup listing.
Server               Comment
---------            -------
Workgroup            Master
---------            -------
WORKGROUP            HOMEASSISTANT

Sorry if the font is all messed up