Trouble connecting RPi to my home wifi

Hi guys,

Sorry that this is another pi zero wifi issue, I’ve searched the forum and can’t seem to a find a post relating to an issue the same as mine. I’ve downloaded the latest image 2.141 for my new pi zero. The zero boots fine but is constantly complaining of wifi power issues on the console (I’ve read elsewhere that this is normal and can be ignored) errors are WLAN0 already exists.

The pi boots fine and volumio starts the hotspot which I can connect to, however, every time I select my home SSID and enter the PSK it takes drops the volumio network for a few seconds before it appears again. The device doesn’t ever seem to join my home network, currently I’m going round in this loop. Could anyone pass on any advice? Thanks

Is your wifi network hidden? What kind of authentication does it use?

hi, no it’s not hidden and no special characters in the said (I know RPis have struggled with that in the past) and I’m using WPA2 personal.

I seem to be experiencing the same issue with a Pi 3, so it looks like this probably isn’t Zero specific. Will update if I find a solution that works for me.

On which channel is your home Wifi network?
You may want to set your region on Volumio so that wifi channels comply:
set REGDOMAIN=xx in /etc/default/crda (xx code from this list), then reboot.
Does it help?

Thank you for your help but it still does not work.
I did the modification in / etc / default / crda (FR for me) but without success.
I can specify that the wifi with RuneAudio works perfectly well … but I would prefer to be able to use Volumio!
Thanks again

Can you try the following:

  • start from a blank re-imaged SD with latest Volumio
  • hook Pi to network with ethernet (not easy for PiZero without an USB-ethernet dongle…)
  • let first boot happen (may take up to 10 minutes on models such as PiZero)
  • Under Volumio UI: Set Hotspot to OFF
  • Under Volumio UI: make sure Wireless is enabled
  • Under Volumio UI: enter Home AP info & credentials, save and reboot.

Any better success?

Hy Macmpi,

What do you mean with " Under Volumio UI "

can you please explain it for analphabets please ?

Kind Regards


I mean using Volumio Web UI to setup/modify settings (particularly network panel in that case).
I’m specific about that because in many cases some users are making modifications to system/config files by editing under ssh, which may generate misunderstanding (and incompatibilities), and make debugging more complex.
So I try to ensure we all speak same language, starting from standard configurations setting.

Okay i ordered an USB-Ethernet Dongle , i will try Configuration with Volumio and let you know if it works.

Kind Regards


Hy champ,

do you have further Experience?
Yesterday I got my usb to ethernet dongle , first it was a little bit tricky to connect my Zero to Lan but with an active USB Hub it works fine.
So i could test finaly my DAC HAT . I tried the mentioned konfiguration Steps but without effect .
So what i know for sure is that i only habe an WLan issue . Today in the afternoon I will try again to get Wifi working .

Kind regards

Gesendet von meinem SM-G930F mit Tapatalk

There are possible issues with latest 2.141 image on Pi (fixed in 2.163 & later images), due to unexpected firmware components changes in the image: this may impact several hardware components, including onboard wifi on Pi3.
It’s likely the same issue with PiZero W.

While waiting for a new release, you may want to replace some files in /boot FAT partition from the SD.
(save original files somewhere to eventually go back).
You may replace all .bin, .elf, .dat files with those from here (and only those 9 files!)
and replace also the 2 following files:

I made all these replacements … but now my RPI3 does not even boot.
It remains blocked and no LED blinks for example

ouch!.. :confused:
Thanks for report.
What was your upgrade path before (from which image, then OTA or re-image?)?
Can you reflash with latest 2.163?

I also did the mentioned replacements
And after i gave the pi zero a static ip adress it also works fine with wlan
Thank you very much for your support.

Kind regards


Now it works also with dhcp

I started again after flashing the RPI3 with the latest version 2.163.
The RPI3 boot well and actually works great with the new driver… but the wifi still does not work. I put the Wireless Network ON and it always returns to OFF …
Sorry to have no better news
Thanks again for your help.

Kind regards

you may want to try the following under console after boot:sudo modprobe -r brcmfmac sudo modprobe brcmfmacDoes it help?
You may have to do it after each reboot. Please confirm if of any help.

Hi Macmpi,
I did that but…Wireless Networking is always OFF
It is of any help
Sorry again


Just to make sure: please start from a re-imaged 2.163 SD, and let first boot take about 8mn before making any change or restarting: yes first boot is important and can take long; not respecting that may lead to all sort of issues.

We can notice in various forums there seem to be some issues with some Pi3 boards and wifi.
Have you successfully used this Pi3 wifi on a Volumio version in the past; If so, which Volumio version?
Have you successfully used this Pi3 wifi with Raspbian?
Which DAC are you using (if any)?
(I know that last question may sound strange, but there are known Pi3 wifi incompatibilities with HiFiBerry DAC+ Pro (

So I just flash the RPI3 with a new version 2.163 and checked the md5sum to be sure of the quality of the image.
I waited 15 minutes after the first boot before trying to connect with WIFI, but it still does not work. Wireless networking is still off

I do not use any DAC; output device is the USB port on which the amplifier is connected.
I never used this Pi3 wifi on a Volumio in the past; but is working well with RUNEAUDIO.
I’ll try the wifi with Raspian and I’ll come back to you.

Thanks a lot