Track displayed is not keeping up with track playing

I have a bit of a problem with g.u.i. keeping up with actual track playing. My set up is -
Pi 3B+ . IQaudio Digiamp+ . Western Digital 500gb usb hard drive with independent 12volt supply . 19volt power supply for Digiamp+ & Pi
8gb class 10 SD card

Running Volumio 2.452 installed on sd card

Connection via lan for my PC - volumio.local/playback and hotspot for my android phone with Volumio app installed.
Album images are all installed as folder.jpg at 300/300 pixels in each album folder

Settings - audio buffer 8mb
buffer before play 20%

Plugins installed GPIO buttons . auto start . backup & restore data

The problem is that some of the time, while continuously playing a long playlist, The displayed track info. sticks at a track playing, next track starts with previous track still displayed. this can happen for all subsequent tracks and so eventually the display is still showing a track that had played some time ago. If I manually forward to next track or go back a track the display rights itself. My first thoughts on this were relating to the fact that the hard drive spins down when idle but I have now discovered that if I add 2 or more radio stations to my playlist the same happens, ie station display often shows the previous station played when I change the the actual station playing. This corrects itself if I stop and then start play.
The problem occurs on both the android phone and on my p.c. using lan.
Could this problem be somehow related to album cache capacity or something like that?

I also have it on version 2.502

Does anyone have any ideas on this? Anyone else having the same problems?

I have the exact same problem, happens quite frequently.

I’m using the web interface via Chrome (latest build, Windows 10).

It happens very frequently that the previous track finishes (left side wheel says 8:22 out of 8:22), title at top has the previous track, tab on browser has previous track, and so on.

If I hit F5 to refresh the browser window, the correct track information appears, with the left wheel showing the total time and a (counting) elapsed time, and the title updating.

(I’m also having issues where sample rate and bit depth aren’t being displayed frequently.

This is on 2.502.

All very strange. I get exactly the same problem on my Android phone using hotspot and using the gui on my win 7 pc which is using lan.
If I hit the stop then play button the correct track playing is displayed. If I do not do this then the display will remain the same as the playing tracks continue to change. Not 100% sure but I think the problem only appears on some albums and not on others. It does happen sometimes also if I have two or three radio stations in the play list and change manually between them.

The refresh of the UI doesn’t work properly in general.

I already posted this bug here: https://volumio.org/forum/bugs-improvements-t10920.html

W/o any response…

Nobody seems to care about it!

I’ve started getting this problem tonight too, track ends and starts another but the ui doesn’t update.
Have to click back to music then back to now playing, then tap the progress wheel to update.

Using iOS app, latest stable volumio release.

So that’s a few of us active forum members having problems now, time for someone to let us know we’ve been heard?

Thanks for your responses so far.
Here is how I see it.
Problem is NOT related to -

  1. Android phone or app. ( same problem on Windows pc with lan connection )
  2. Music tags incorrect ( same problem with web radio )
  3. Album art problems ( as above )
  4. Audio buffer size ( tested at all settings from 128kb to 12mb )
  5. Buffer before play ( tested all settings from 10% to 40% )
  6. All other playback options ( tried all settings)
  7. Reset album album art cache ( tried it )
  8. Release version ( tested with latest version and with previous 3 versions)

Any ideas on fixing this annoying problem with an otherwise excellent program?
Any thoughts on it Michelangelo?

I can confirm that this is still an issue in version 2.873. I’m playing an Elvis song right now but the user interface says I’m listening to the Beatles.