Touchscreen Plugin - Grey Screen with Mouse Pointer [SOLVED]


i rencently installed Volumio on my RPI 3 with attached 10.1 inch Waveshare touchscreen. The installation worked fine, configuration via a second pc and network worked flawless. Now I was trying to install the touchscreen input plugin for which the installation worked also fine without errors. I activated the plugin but all I got now is a grey screen with a mouse pointer (which I can indeed move by touch input). No Volumio webinterface is visible. After looking in the menu of my Touchscreen I saw that it is displaying a resolution of 1920x1200x60Hz which seems to be wrong since it supports natively only 1024x600. I configured this properly in /boot/config.txt:

hdmi_cvt 1024 600 60 6 0 0 0

but I guess volumio is still setting a wrong resolution for the XServer? Is there any chance to correct this? Any help is appreciated!

Please search the forum, your issue with Waveshare has been discussed a few times.

– Gé –


thanks for your quick reply. The only thread I found is closed with the solution of a reinstallation of the plugin which I tried several times? Am I missing a thread or something?

I searched again but I din’t find any helpful information. I’m not even exactly sure what the problem is? Is it a general problem with hdmi output or especially with waveshare displays? Most Waveshare users are having trouble with touch rather than video output. I’m really stuck now, any help would be very nice! Thanks!

… after some more research it seems like it is a problem related to chromium and nothing specific to the display (which seems to work fine). In the .xsession-errors I found following error(s):

/opt/ line 7: /usr/bin/chromium-browser: No such file or directory
Obt-Message: Xinerama extension is not present on the server

Seems that something went wrong during touch plugin installation with the chromium package (also I searched the whole installation output without finding any errors…).

Regarding Chromoium is stated:
Installing Chromium Dependencies
Download Chromium
Install Chromium

but if I mount the sd card to another pc I can’t find any packages related to chromium so it seems like Download isn’t working…

…and now I found out, that this might be due to missing space on the sd card. I dd’ed the img file to a 64GB SD Card which worked well but the volumio_data partition has only 19MB free (which is too less for downloading chromium). It is a little bit strange since in Linux Mint Disk utility is shown that volumio_data has 62GB but 99,9% is used? In nemo is shown that volumio_data has only 370MB, with 99 percent used??


OK so the problem was, that the filesystem of the volumio_data partition was not resized to the whole partition size which I did with gparted. The I ran the plugin installation routine again and voila everythings works very well! So maybe this is helping someone in the future to avoid this stupid mistake :wink: Would be nice if the installation routine checks the available disk space and throws an error.