Touch display how to avoid shell screen display during boot

Hello community,

I have a volumio install with touch display and official raspi display working perfectly fine, it is embedded in a nice aluminium case making it looking very professional and “high-end”.

So my question is much more cosmetic than troubleshooting a bug :wink:

During boot, the display shows first a VOLUMIO picture splash screen, then switch to to console mode before loading graphic user interface.

I wondered if it was possible to avoid showing the console, either maintaining the VOLUMIO splash screen until the graphic user interface is fully loaded or just a black screen. This would make the startup more “professional” looking.

If there is a Config file that could be modified or another tweak that could provide that boot cosmetic, I would be happy to know.


Connect to Volumio via SSH and execute

sudo systemctl disable getty@tty1.service

It works perfectly - thanks a lot for the trick.

1 Like

@gvolt not working for 3.xx

On Volumio 3.x in “/boot/cmdline.txt” “loglevel” ist set to 8, probably because it’s a beta :wink: Just set loglevel=0 as in Volumio 2.882.

If there should still appear some messages, also change “console=tty1” to console=tty3 in “/boot/cmdline.txt”.

That’s weird IMHO :thinking: …but good :grin:

@gvolt spoke 2 soon tried again cold boot and it was off again…

Everything other would have been… weird :wink:

Maybe report the issue in the RPi Buster beta thread (if you should not done so already).

@gvolt did that already … even added the jump to 0 of the volume… was set on 45

1 Like