Touch cursor position wrong

Problem

The touch cursor position is wrong (it is reflected across the screen from the position touched). That is, touch lower left corner, cursor arrow appears in upper right. Touch left of center, cursor appears right of center. On the positive side, once the right position has been found (by touching on the opposite side of the screen from that control), the desired control operates as expected.

Just installed this month for the first time. How to diagnose and resolve this problem? Is it the settings in /boot/userconfig.txt?

Volumio Information

Volumio Version: 2.806
Hardware: Raspberry PI 3B, Official 7" Touch Screen (TouchDisplay 1.1.9 plugin)
DAC: headphone

TouchScreen is wired as shown in photograph of step 1 in the instructions. Mounted in official case (from oneninedesign).

volumio@volumio:~$  tail -5  /proc/cpuinfo

Hardware        : BCM2835
Revision        : a22082
Serial          : 0000000005975271
Model           : Raspberry Pi 3 Model B Rev 1.2

volumio@volumio:~$ cat /boot/config.txt
initramfs volumio.initrd
gpu_mem=32
max_usb_current=1
dtparam=audio=on
audio_pwm_mode=2
dtparam=i2c_arm=on
disable_splash=1
hdmi_force_hotplug=1

include userconfig.txt


dtparam=spi=on

volumio@volumio:/boot$ cat /boot/userconfig.txt

# https://www.raspberrypi-spy.co.uk/2017/11/how-to-rotate-the-raspberry-pi-display-output/
### pick one of these
# 0 degrees (default)
# display_rotate=0
# 90 degrees
# display_rotate=1
# 180 degrees
display_rotate=2
# 270 degrees
# display_rotate=3# Add your custom config.txt options to this file, which will be preserved during updatesvolumio@volumio:/boot$

Try removing display_rotate=2 from /boot/userconfig.txt and use the rotation option on the config page of the touch display plugin.

Thanks. First try with that idea (before you replied) and display did not work at all (no output to display, even on warm reboot).

Now:

  1. uninstall plugin
  2. remove rotations from userconfig
  3. power cycle
  4. reinstall & activate plugin
  5. restart (no power cycle): touch display is upside down
  6. plugin’s rotation configuration (for 180 degrees)
  7. restart (no power cycle), no image on touch display

Web page active, ssh login active, no touch display at all :frowning:

What next?

Please post the results of
cat /boot/config.txt
cat /boot/userconfig.txt and
systemctl status -l volumio-kiosk.service

Thanks for your assistance. Here’s the info:

                       ___
                      /\_ \                        __
         __  __    ___\//\ \    __  __    ___ ___ /\_\    ___
        /\ \/\ \  / __`\\ \ \  /\ \/\ \ /' __` __`\/\ \  / __`\
        \ \ \_/ |/\ \L\ \\_\ \_\ \ \_\ \/\ \/\ \/\ \ \ \/\ \L\ \
         \ \___/ \ \____//\____\\ \____/\ \_\ \_\ \_\ \_\ \____/
          \/__/   \/___/ \/____/ \/___/  \/_/\/_/\/_/\/_/\/___/

             Free Audiophile Linux Music Player - Version 2.0

          C 2015 Michelangelo Guarise - Volumio Team - Volumio.org


Volumio Debian GNU/Linux comes with ABSOLUTELY NO WARRANTY, to the extent
permitted by applicable law.
volumio@volumio:~$ cat /boot/config.txt
initramfs volumio.initrd
gpu_mem=32
max_usb_current=1
dtparam=audio=on
audio_pwm_mode=2
dtparam=i2c_arm=on
disable_splash=1
hdmi_force_hotplug=1

include userconfig.txt


dtparam=spi=on
volumio@volumio:~$ cat /boot/userconfig.txt

# https://www.raspberrypi-spy.co.uk/2017/11/how-to-rotate-the-raspberry-pi-display-output/
### pick one of these
# display_rotate=0    # 0 degrees (default)
# display_rotate=1    # 90 degrees
# display_rotate=2    # 180 degrees
# display_rotate=3    # 270 degrees
# Add your custom config.txt options to this file, which will be preserved during updates


#### Touch Display rotation setting below: do not alter ####
display_lcd_rotate=2
display_hdmi_rotate=2volumio@volumio:~$ systemctl status -l volumio-kiosk.service
● volumio-kiosk.service - Volumio Kiosk
   Loaded: loaded (/lib/systemd/system/volumio-kiosk.service; disabled)
   Active: active (running) since Mon 2020-08-24 16:08:39 UTC; 8min ago
 Main PID: 1443 (startx)
   CGroup: /system.slice/volumio-kiosk.service
           ├─1443 /bin/sh /usr/bin/startx /etc/X11/Xsession /opt/volumiokiosk.sh -- -nocursor
           ├─1470 xinit /etc/X11/Xsession /opt/volumiokiosk.sh -- /usr/bin/X :0 -nocursor -auth /tmp/serverauth.LKKZWGeYFR
           ├─1471 /usr/lib/xorg/Xorg :0 -nocursor -auth /tmp/serverauth.LKKZWGeYFR
           ├─1601 /bin/bash /opt/volumiokiosk.sh
           ├─1618 /usr/bin/ssh-agent /opt/volumiokiosk.sh
           ├─1623 /usr/bin/openbox --startup /usr/lib/arm-linux-gnueabihf/openbox-autostart OPENBOX
           ├─1624 /usr/lib/chromium-browser/chromium-browser --enable-pinch --ppapi-flash-path=/usr/lib/chromium-browser/libpepflashplayer.so --ppapi-flash-args=enable_stagevideo_auto=0 --simulate-outdated-no-au=Tue, 31 Dec 2099 23:59:59 GMT --disable-pinch --kiosk --no-first-run --noerrdialogs --disable-3d-apis --disable-breakpad --disable-crash-reporter --disable-infobars --disable-session-crashed-bubble --disable-translate --user-data-dir=/data/volumiokiosk http://localhost:3000
           ├─1650 /usr/bin/pulseaudio --start
           ├─1657 /usr/lib/chromium-browser/chromium-browser --type=zygote --noerrdialogs --user-data-dir=/data/volumiokiosk --ppapi-flash-path=/usr/lib/chromium-browser/libpepflashplayer.so
           ├─1662 /bin/sh /usr/bin/start-pulseaudio-x11
           ├─1663 /usr/bin/xprop -root -spy
           ├─1666 /usr/lib/chromium-browser/chromium-browser --type=zygote --noerrdialogs --user-data-dir=/data/volumiokiosk --ppapi-flash-path=/usr/lib/chromium-browser/libpepflashplayer.so
           └─1724 /usr/lib/chromium-browser/chromium-browser --type=renderer --disable-3d-apis --disable-breakpad --disable-pinch --enable-pinch --enable-features=AutofillCreditCardSigninPromo<AutofillCreditCardSigninPromo,AutofillProfileCleanup<AutofillProfileCleanup,DocumentWriteEvaluator<DisallowFetchForDocWrittenScriptsInMainFrame,ExpectCTReporting<ExpectCTReporting,IncidentReportingDisableUpload<SafeBrowsingIncidentReportingService,IncidentReportingModuleLoadAnalysis<SafeBrowsingIncidentReportingServiceFeatures,IncidentReportingSuspiciousModuleReporting<SafeBrowsingIncidentReportingServiceFeatures,MaterialDesignUserManager<MaterialDesignUserManager,NegotiateTLS13<TLS13Negotiation,NetworkTimeServiceQuerying<NetworkTimeQueries,NewAudioRenderingMixingStrategy<NewAudioRenderingMixingStrategy

Aug 24 16:08:40 volumio startx[1443]: (++) from command line, (!!) notice, (II) informational,
Aug 24 16:08:40 volumio startx[1443]: (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
Aug 24 16:08:40 volumio startx[1443]: (==) Log file: "/var/log/Xorg.0.log", Time: Mon Aug 24 16:08:40 2020
Aug 24 16:08:40 volumio startx[1443]: (==) Using config directory: "/etc/X11/xorg.conf.d"
Aug 24 16:08:40 volumio startx[1443]: (==) Using system config directory "/usr/share/X11/xorg.conf.d"
Aug 24 16:08:40 volumio startx[1443]: modprobe: FATAL: Module g2d_23 not found.
Aug 24 16:08:42 volumio startx[1443]: modprobe: FATAL: Module g2d_23 not found.
Aug 24 16:09:10 volumio pulseaudio[1650]: Unable to contact D-Bus: org.freedesktop.DBus.Error.Spawn.ExecFailed: /usr/bin/dbus-launch terminated abnormally without any error message
Aug 24 16:09:10 volumio pulseaudio[1650]: Unable to contact D-Bus: org.freedesktop.DBus.Error.Spawn.ExecFailed: /usr/bin/dbus-launch terminated abnormally without any error message
Aug 24 16:09:10 volumio pulseaudio[1650]: org.bluez.Manager.GetProperties() failed: org.freedesktop.DBus.Error.UnknownMethod: Method "GetProperties" with signature "" on interface "org.bluez.Manager" doesn't exist

It seems your display is not recognized as a Raspberry Pi display. Otherwise the entry in /boot/userconfig.txt should be lcd_rotate=2 instead of display_lcd_rotate=2

Please test the following:

  1. Disable the touch display plugin.
  2. Check if the touch display’s entry has been removed from /boot/userconfig.txt.
  3. If so, in a second terminal execute sudo journalctl -f | grep touch_display.
  4. Enable the plugin again and watch the logs for a message No Raspberry Pi Foundation touch screen detected. or Raspberry Pi Foundation touch screen detected.

P.S.: Do you use dedictated cables for SDA and SCL? If so, try disconnecting them. With the Pi3 SDA and SCL signals are transmitted via the DSI ribbon cable.

1 Like
  1. Touch plugin OFF
  2. checked /boot/userconfig.txt: no uncommented *display=* lines
  3. found: volumio volumio[1048]: info: touch_display: No Raspberry Pi Foundation touch screen detected.
  4. Aha! Yes, using yellow and green cables as shown in the docs.
  5. Remove yellow and green (SDA & SCL) cables from RPi motherboard (power off, remove cables, power on)
volumio@volumio:~$ sudo journalctl -f | grep touch_display
Aug 24 16:35:38 volumio volumio[1048]: info: Enabling plugin touch_display
Aug 24 16:35:38 volumio volumio[1048]: info: Loading plugin "touch_display"...
Aug 24 16:35:38 volumio volumio[1048]: info: Applying required configuration parameters for plugin touch_display
Aug 24 16:35:38 volumio volumio[1048]: info: PLUGIN START: touch_display
Aug 24 16:35:38 volumio volumio[1048]: info: touch_display: systemctl daemon-reload succeeded.
Aug 24 16:35:38 volumio volumio[1048]: info: touch_display: systemctl start volumio-kiosk.service succeeded.
Aug 24 16:35:38 volumio volumio[1048]: info: touch_display: Volumio Kiosk started
Aug 24 16:35:38 volumio volumio[1048]: info: touch_display: No Raspberry Pi Foundation touch screen detected.
Aug 24 16:35:38 volumio volumio[1048]: info: touch_display: Using Xserver unix domain socket /tmp/.X11-unix/X0
Aug 24 16:35:38 volumio sudo[5852]: volumio : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/bin/sed -i -e /Option "TransformationMatrix"/d /etc/X11/xorg.conf.d/95-touch_display-plugin.conf
Aug 24 16:35:39 volumio volumio[1048]: info: touch_display: Touchscreen transformation matrix removed.
Aug 24 16:35:39 volumio volumio[1048]: info: touch_display: Setting screensaver timeout to 120 seconds.
Aug 24 16:35:39 volumio sudo[5872]: volumio : TTY=unknown ; PWD=/ ; USER=root ; COMMAND=/bin/sed -i -e /Identifier "Touch rotation"/a\        Option "TransformationMatrix" "-1 0 1 0 -1 1 0 0 1" /etc/X11/xorg.conf.d/95-touch_display-plugin.conf
Aug 24 16:35:39 volumio volumio[1048]: info: touch_display: Touchscreen transformation matrix written.

… rebooting now, please stand by …

Thanks! All is working now!

  1. Don’t use SDA/SCL cables with RPi3
  2. Don’t set display rotation manually (in either /boot/config.txt or /boot/userconfig.txt)
  3. Let the plugin control screen rotation
  4. Let the wookie win.
1 Like

Please mark the thread solved :wink:

Is the post marked as solved now?

Yes, for me it’s marked as solved. :slight_smile:

1 Like