Tidal mqa with Volumio or MyVolumio

Hi,
I’m new to Volumio and RPI based streamer and have a few questions regarding how it works.
I have a USB MQA decoder (SMSL M500) which can fully decode MQA (so no first unfold needed by the player). I know there are debates on mqa but I need to get it work as Tidal is the only hires option where I live. I want a setup the system so that I can use my iPhone to control bit-perfect playback of my DSDs (on NAS via SMB) and Tidal master. I saw some review mentioning Mconnect player on iOS can send Tidal Master/local DSDs bit-perfect to Volumio, which then forward to USB DAC for decoding MQA and DSD. My questions are:

  1. Has anybody tried it and does it work for Tidal MQA and local DSD files?
  2. Does the music play through Mconnect on iOS or it just send the URL and Volumio stream directly from Tidal or NAS?
  3. I noticed there is a paid option “MyVolumio” which seems to have native Tidal integration. Does it support MQA and what are the benefits of MyVolumio vs free version?
  4. Any suggestion for high SQ usb hardware which support Volumio?
  5. I currently use Logitech Harmony to control all devices, can Harmony be used power on/off and playback in Volumio?

Any help is appreciated!

I have a Raspberry PI 4 / 4 Gig and I am able to get full MQA into my MQA DACs. All MQA files are FLAC files and if your DAC sees and MQA .flac file it will expand it to the full MQA resolution of 352/24bit or whatever the original MQA bit rate. I purchased the virtuoso license.
Also I am to play DSD files from my Kodi server to my DAC through my Volumio.

With Tidal and Volumio? That doesn’t happen in my system, they’re restricted to 24/48khz. If I okay them via Audirvana and Volumio, they indeed are full resolution, but not inside Volumio.

Hi there, what USB cable are you using from your Raspberry PI to your MQA DAC? I used just the standard USB cable (the small one provided) with my Magna Mano Raspberry PI and it actually worked, but wanted to upgrade to the Curious USB cable, but Volumio is not recognizing the new Curious USB cable in the audio output device settings. Any ideas?