TIDAL Connect - Roon conflict

I’m having problems trying to run both TIDAL Connect and Roon bridge/endpoint on Raspberry PI 4. All the other music sources are switched off. External DAC connected via USB.

After Raspberry restart Volumio (and DAC connected to it) is visible in both TIDAL and Roon. But if I start using one of them it’s impossible to switch to the other one without restart.

I guess neither of those mechanisms releases ALSA on the Raspberry when playback ends.

Is that how it should work?
Any configuration that can make it working better?
Do you plan to fix that? When?

Unfortunately that’s a deal breaker for me :frowning:


Update: it works better on experimental release 2.909. Will be testing…

Sounds similar to my situation. I have a Allo Digione (Rasberry PI + Digione HAT). I have upgraded to the Volumio level that supports using the Digione as a Tidal Connect endpoint. I am also experimenting with Roon by running CORE on a PC and the Digione as an output. If I use either Tidal or Roon exclusively the Digione works fine. However once the Digione has played content from Tidal, I cannot connect to the Digione from Roon (error message related to Roon cannot open device) without rebooting both the PC and the Digione. Once the reboots are complete then Roon can connect again to the Digione.

Anyone know a solution for this issue?

I’ve contacted support and they replied that:

“Roon plugin is a third party developed plugin, not official, developed by our community users. It’s free and not full guarantee, especially on the latest sw versionsAbout this kind of issue I suggest to ask to the developers directly. You can find their names in the plugin section and you can contact them via community forum community.volumio.org

So Volumio doesn’t care much abou that feature :frowning:

no the support part is by the creator of the plugin and not by the core of volumio.
and volumio as the core doesn’t support it … so it’s not that they don’t care about it
they didn’t build it so they can’t help you with it.

I will contact the plugin developer and provide hints on how to solve this issue. Thanks for pointing it out :wink:

1 Like

I have the same issue:

  • Roon → Volumio Roon Bridge works fine.
  • Tidal Connect → Volumio works fine.
  • But after using Tidal Connect, Roon complains with “Failed to open the Audio device”

Rebooting the Pi re-enables Roon Bridge connectivity, but this is less than ideal. Hopefully the plugin developer will chime in…

@PiotrP & @volumio,
Have these issues been resolved? I primarily use Roon, but I’d like to add Tidal Connect capability. A paid Volumio plan would be worth it if it can reliably switch between the two.

I don’t know.
After the trial last year I decided that Volumio was not mature enough and haven’t prolonged subscription.

1 Like