Tidal connect not working with usb accuphase dac-40

Volumio Information

Volumio Version:2.882
Hardware: RPi-3B
DAC: accuphase dac-40 (usb)

all is working perfectly(except tidal connect). I am able to play from tidal through gui, roon, airplay stream, spotify and also local file streaming to the dac.
just when enable tidal connect then it stuck.
tidal connect is visible on iOS, and macos, but not windows
in app it shows it is connected and playing but paused at the beginnig (all apps are up to date)
in volumio ui i see it is connected, the songs looks like playing, but cycled in a 21 seconds circle. NO SOUND.

tried; i did a fresh new install, just wanted to test tidal connect
connected a tidal account and activated Virtuoso
changed mixer type to Software
tried to enanble and disable MPD volume control
DSD is for local playback, so I assume it has no effect, also audio resampling, the same.
tried to reboot several times and or disable/enable tidal connect on volumio

any other thoughs what I can try?

thx. Martin

thanks a lot to fantastic support, Davide. the issue resolved with using a custom DNS, while the default settings was blocking the connection. :slight_smile: so it was the network problem on my side, causing an issue of playing with T. connect, but working with standard tidal client playing from Volumio.