Tidal Connect not working anymore on RPi 4 with Allo Digione

Hey guys, so I have an Allo Digione running on a Raspberry Pi 4 that I bought directly from Allo. It was working fine with both Spotify and Tidal Connect, however Tidal connect just stopped working randomly the other day. It connects just fine, but I get no audio and playback is stuck as if it’s paused.

I see it playing back from the web interface and the song is actually progressing, but still no audio. So I thought, well maybe my installed is just borked, so I actually just did a fresh install of the latest 3.x build. And I have the exact same issue after setting it up. I know it’s not a hardware/config issue, because Spotify connect actually still works just fine on the 3.x fresh build. What concerns me is that I’m seeing the same exact issue on 3.x that I saw on the latest 2.x build before, so it doesn’t seem like like it’s version related.

I have no clue how to troubleshoot this, because Tidal Connect is the only reason I am using Volumio at all. I have a premium subscription to volumio and I spent $500 on this whole setup, so I’m pretty frustrated that I am sitting on a $500 paperweight right now. Are there logs or something I can check to try to isolate what the root cause of the issue is? It just doesn’t make sense because it has literally been working fine the past few months, and out of the blue it just randomly doesn’t work, even after doing a fresh install. I’m at a loss and honestly and wish I would have just bought an actual streamer device because that runs firmware and not a whole O/S… Linux is just such a huge pain in the ass and it’s never stable in my experience. It always randomly breaks for no good reason and you end up wasting days trying to just get it working.

Sorry for the long rant, but any help is greatly appreciated though. I’m just really frustrated that I can’t listen to music on Tidal right now.

Would you share some system logs please?

Preferable from a fresh reboot, with minimal steps to reproduce the problem :slight_smile:

So this makes no sense. It randomly just started working again today. I didn’t even do a reboot or change anything. I’ll provide logs if I run into the issue again but it seems to be fine now…. So weird.

Send them next time you have issues, also with other ones.
They are extremely helpful for community supporters and devs.
Enjoy your time here!