Tidal Connect limited to 48khz via RPi4B, Allo DigiOne to SMSL SU9 MQA Full Decoder

Hey guys,

Im new to volumio and I hope you can help me out with my issue. I’ve read through threads here in this board for a few hours, but I couldn’t fix it myself.

I am trying to play MQA songs from Tidal with 192khz via Tidal Connect. Songs are playing but the sample rate is allways limited to 48khz / 24bit shown on my DAC. Via USB connected to the Tidal App on my PC it is working. The same song with sample rates up to 192 khz is displayed on my DAC.
So there seems to be that my DAC is not recognising the MQA properly?

I am using a RPi 4b with a Allo Digone and a SMSL SU9, so a MQA Full Decoder.
Sure I have a suiteable Hifi Plus subscription with Tidal.

I know that many users already reported the same issueb that 44/48 khz are somehow the maximum with tidal connect, but failed because their dacs are not able to do the full decodation. With mine it should be possible.

So I wonder why this is not working.
I have a fresh installed Volumio. No further installed plugins.

Is there any specific settings i have to set in order to get the full MQA data “passed through” to my DAC to do the full decodation and unfolds?

I tried the tip for a “bit perfect passthrough” from another user here. Please correct me if I mistook it:

  • You select “High resolution” in the TIDAL settings → Done
  • Volume is set to 100 → within “volume Options” in the general playback options the mixer type is set to “none”. With my DAC its set to max (99 with the SU9)
  • No plugin like equalizer or resampling is active → Its fresh set up volumio. No plugin is installed and no resampling is active

What else can i do? It is really dissapointing that this is not working properly, since the first experience with volumio were really good.
So yeah having the possiblity to stream MQA full master quality up to 192khz via volumio and Tidal Connect was the only reasing for this use case and I hope you guys can help me out!

Thank you very much!
Kennz

Is your SMSL capable to run MQA over S/PDIF, as most DAC’s don’t support this. Hence that’s why it is working on your PC, using USB. I expect if you connect the SMSL to the pi over USB it will work.
In your case your playing the Master recording as the lossy audio container (48k)

See for example: audiosciencereview

I cannot beleave this!

First of all thank you very much for your very quick reply! Thats awesome.
Second im shocked! Yes, connecting the Raspberry with the DAC via USB Volumio still shows 48khz/24bit, but my DAC shows 192khz and the blue dot for a certified MQA track.
So yeah, appearently S/PDIF seems to be the reason and my allo digione OR my SU 9 has completely lost its reason to exist in my setup.
What am I doing now… Guess I have to figure out later if the soundquality via the RPi 4b USB is fine too, or search for a new DAC that supports MQA via S/PDIF.
Do you know one maybe??

Gosh… grounded…

Volumio is not certified for MQA, so you’ll see the format of the audio container in Volumio (48K), however Volumio passes the full MQA signal to the SMSL if you use USB.
The Audio quality over USB is good with the rPi4 as they have separated the network from the USB bus. (with the rPi3 it was shared)
I would not spend money on a new DAC, but simply remove the Digione. Or if you have a spare rPi built 2 systems :-). Since MQA is already a lossy format, you will not notice a degradation of the sound.

See also:

Yeah… now I know the reason I will sleep over it since its already 2 am in Germany…

Tomorrow i will give it a try and compare the sound over USB via the existing one. Eventhough its nonsense since the DAC does not decode the files via S/PDIF.
AND I will compare it to the allo digione plus the Smsl dac using Tidal Hifi, so CD Lossless quality and maybe I will just step back from the High Res playground for now.

Considering qobuz as an alternative to MQA is an option, but the price differences between those are just to high in my case.

Thank you very much again!

All the best to you
Kennz

Go for Qobuz :slight_smile: its cheaper and better

Also going to stop, same timezone, but closer to the north sea :slight_smile:

2 Likes