Tidal Connect is not playing "Attempting to initialize a decoder without initial data!"

Hi!

I don’t get any sound when using Tidal Connect, but I see the song playing in Volumio.
Tidal and local files isn’t any problem.

My setup:
Volumio: 3.165 (2.917 has same issue)
Platform: RPi 4 4GB
USB DAC: Audiolab M-DAC+
Connection: WiFi

I have tried every fix I’ve been able to find, but none of them help.

In /dev/ Live Log I get error:
[2021-12-07 18:24:37.547] [tisoc] [warning] [logger.cpp:22] [audio_worker.cpp:326] Attempting to initialize a decoder without initial data!

Thanks for reporting!
@mervinio will have a look and help!

Same issue here
RPi3 with HifiBerry DAC2HD
Did a fresh install with a new SD-Card
Updated to 3.175, but Tidal connect is still not working.

Virtuoso subscription.

Hi @volumio
I’m on 3.196 now, and Tidal Connect still won’t work.
Is there anything I can try to fix this?
Has @mervinio looked at it?

Hi,
The Volumio OS 3.++ has made this start of the year 2022 worse than the pandemic itself. Being locked up is one thing but without a working “streamer” solution, well, need I say more.
So Tidal Connect no longer connects if you are on RPI4. This after some rather pathetic attempts at getting it right.
So all or most of the plugins have gone South with the change to the incredible Volumio v. 3.++ even those I actually paid to acquire a license. Not very professional if I may say.
So should I join the few that have opted out or rather rolled back to the last version before your pitiful roll out of Volumio v. 3.++
Quick question, don’t you guy’s have testing procedures and soft release structure in-place before rolling out a new - meaning change the version number before the dot - do you pray to the Madonna and hope it works.
If you haven’t noticed by now, this is one NOT happy client.

Instead of ranting and getting extremely impolite, you will be far quicker getting your problem solved when you focus on describing your issue and submit a log.
Your problem is not a general one, I’m using TC daily and don’t have any issues with it.
How to send a log

You don’t seem to realize, that plugins are not part of the Volumio product, you are getting these free of charge from community members, who spend a lot of their free time to develop them.
Some are still working on getting them onto the new Volumio 3 plugin store.
Every plugin needs to be reviewed and this takes time.
Current plugin migration status

Any update on this? I’m having the same issue with the following setup:

Volumio 3.198
RPi4B 2G with HiFiBerry DAC2 Pro
Wifi

FWIW it is consistently the same songs that demonstrate this issue (e.g. Heavy by The Glorious Sons)

I see this in the logs:

[2022-01-25 23:35:46.078] [tisoc] [error] [logger.cpp:25] [operation_curl.cpp:257] curl_easy_perform failed: Stream error in the HTTP/2 framing layer - HTTP/2 stream 0 was not closed cleanly: INTERNAL_ERROR (err 2)
[2022-01-25 23:35:46.079] [tisoc] [error] [logger.cpp:25] [http_stream_fetcher.cpp:162] Content-Range is missing from response!
[2022-01-25 23:35:46.420] [tisoc] [error] [logger.cpp:25] [operation_curl.cpp:257] curl_easy_perform failed: Stream error in the HTTP/2 framing layer - HTTP/2 stream 0 was not closed cleanly: INTERNAL_ERROR (err 2)
[2022-01-25 23:35:46.421] [tisoc] [error] [logger.cpp:25] [http_stream_fetcher.cpp:162] Content-Range is missing from response!
[2022-01-25 23:35:46.775] [tisoc] [error] [logger.cpp:25] [operation_curl.cpp:257] curl_easy_perform failed: Stream error in the HTTP/2 framing layer - HTTP/2 stream 0 was not closed cleanly: INTERNAL_ERROR (err 2)
[2022-01-25 23:35:46.775] [tisoc] [error] [logger.cpp:25] [http_stream_fetcher.cpp:162] Content-Range is missing from response!
[2022-01-25 23:35:46.780] [tisoc] [warning] [logger.cpp:22] [audio_worker.cpp:293] Max connection attempts reached!
info: Unknown command: notifyPlaybackError

Thank you rodb for the information. We are hunting this bug since it was initially reported, but we never managed to replicate it or to understand the root cause.
This is a very useful pointer!

The TIDAL Connect implementation relies on a library that TIDAL provided us, upon which we can’t introspect much, this makes it even harder to troubleshoot it.
Then, we have a very little number of reports of such issues, this makes troubleshooting even harder.

We are in touch with TIDAL to figure out what the root cause might be and rest assured that this is on our top 3 priority list.

We will keep you posted.

You have all the right of being dissatisfied by how Volumio works for you. Our job is to deliver a flawless experience, and we are failing at it, despite our best efforts.

What you don’t have the right to do is assume you know better and that is a QA issue, when the reality is much more complex than that and not fully under our control (the latter is however not an excuse for us), and most important writing such a irrespectful way of qualitfying people working in this project.

Rant at the product, not at the people.

Hi,

Now I’m running 3.254, and Tidal Connect WORKS on my setup. :clap: