The opposite behavior of the DSD settings

I did not try it yet in vol 3, I have only a few albums in dsd format… I wait a feedback from volumio…

1 Like

… maybe in your opinion changing from RPi 4 to Asus tinker board 2S will be the right solution (different kernel ?) ???

There is no support for Tinkerboard 2S and there are no plans for it.
Did you try different usb ports?
Could you give us the “lsusb -t” output, just for checking the kernel usb audio driver sources once more?
Also do “uname -a”

volumio@volumio-salon:~$ lsusb

Bus 002 Device 002: ID 2109:0711

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub

Bus 001 Device 003: ID 16d0:071a MCS

Bus 001 Device 002: ID 2109:3431

Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

volumio@volumio-salon:~$ lsusb -t

/: Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/4p, 5000M

|__ Port 1: Dev 2, If 0, Class=Mass Storage, Driver=usb-storage, 5000M

/: Bus 01.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/1p, 480M

|__ Port 1: Dev 2, If 0, Class=Hub, Driver=hub/4p, 480M

|__ Port 4: Dev 3, If 0, Class=Vendor Specific Class, Driver=, 480M

|__ Port 4: Dev 3, If 1, Class=Audio, Driver=snd-usb-audio, 480M

|__ Port 4: Dev 3, If 2, Class=Audio, Driver=snd-usb-audio, 480M

volumio@volumio-salon:~$ uname -a

Linux volumio-salon 4.19.118-v7l+ #1311 SMP Mon Apr 27 14:26:42 BST 2020 armv7l GNU/Linux

I believe you will find a solution to my problem, please … the only hope is in you :slight_smile:

i don’t get it, your alsa output from stream0 says there is no DSD support.
Looking at the 4.19 kernel it looks like it should, but there are some “buts” for Amanero devices, there are obviously additional with alt-settings, which I can’t explain but give you no DSD support. Is this why yours doesn’t work?You would need to contact Amanero, I can’t help any further.

Has DoP been fixed then ? as this was an issue in the Beta back in October here and I still have the same problem in 3.173

If DoP is enabled the DAC reports a PCM 176 input, but the only thing heard is slight static and feint music until the volume reaches 100% (Volumio volume) then the DAC reports 2.82 MHz DSD and all plays fine.

1 Like

volume always has to be 100%, otherwise you won’t get bit perfect, which is needed for a dsd direct stream!
Sorry for not mentioning this earlier, this is with all DSD dacs I know of.

That is correct for DSD Direct… But what about DoP

Doesnt the DoP setting in Volumio transcode the DSD data into a PCM stream on the fly ?

Ok Thx. apart from Amanero compatibility, there is still the issue of glitches. After setting DoP in vol.2 I have the correct sound; after switching to vol.3 and setting DoP there are distinct crackles in the background. After switching to DSD direct, the sound is muffled with a significantly worsened stereo, but without glitches (the DAC shows PCM then). In my opinion, the cause of the glitches may be the DAC synch mismatch - which would indicate that in the vol.3 version something changed with the clocks (?) Anyway, in the vol3 version I can’t listen to DSD even through DoP (!)

I have two more sets where the DAC (ES9038 SABRE) is connected directly to I2S RPi 4 and RPI-DAC set in Volumio; and the problem of clicks and reversed DoP settings is the same as in the previous case.

volumio@volumio-sypialnia:~$ uname -a

Linux volumio-sypialnia 5.4.83-v7l+ #1379 SMP Mon Dec 14 13:11:54 GMT 2020 armv7l GNU/Linux

Are you saying that the volume needs to be at 100% for DoP as well ?

I think I may have misunderstood what DoP actually does

As for the 100 percent volume issue, a DSD bitstream should never be modified prior to sending it to the DAC. This means that for this you should never use Volumio with the software mixer selected. The output volume must be set to 100 percent to keep the stream bit perfect, some DACs have an algorithm to do volume control in hardware. The DAC I use for testing, Khadas Tone, has hardware mixer, but must also be set to 100% to get sound, obviously it modifies the stream as well which results in white noise otherwise. I don’t know your DAC, can’t say how it behaves.

Could you please reply to my last two posts? … and by the way, I bought another Amanero module, after connecting only to the volumio it behaves like the previous one - so this is not a problem of a specific module, but rather volumio drivers for Amanero. It is a pity because it is a popular module known for its good sound quality; maybe it is worth the volumio team to do something about it (?)

PS I also wrote to the Amanero’s autor …

And could you please be a little patient? Your last post was only 15 hrs ago!
I’m a community volunteer and not here 24x7 just to help you out.

I think you misunderstand, there are no Amenero drivers in Volumio.
The Linux kernel (in our case the one supplied by the Raspberry foundation) only has one single driver for all USB DACs.
To make it work with DSD and your model, Amanero needs to comply with the standards and ask kernel.org to “register” the model’s details in the usb driver’s quirks list.

If you would care to google a little, you will see, that more people have issues with Amanero and RPi. Also with other streamer software.

Edit DSD capability with Amanero Combo384 obviously depends on the device’s usb revision number. It must be 0x199, 0x19b or 0x203.
with 0x199 you are supposed to get DSD_U32_LE, with the other two, DSD_U32_BE.

I also found the DSD setting is reversed on my Pi 3B+ with both Volumio 2 & 3. My DAC work well with PC running with Footbar2000. However, I must set DoP on Volumio to have DSD bit rate.
Regarding the cracking noise, I found that it happen when I enabled the Touch display plugin. Once I disabled the Touch display plugin, no more noise.

1 Like

PS: I also use Amanero USB.

I was under the impression that when DoP is enabled, Volumio was transcoding the DSD data to a simple 24Bit 176KHz stream but it seems is not the case, as there is no sound.

My DAC is a Topping D10 . It supports DSD up to 256 and has a hardware mixer.

I was hoping that with DoP enabled I wouldnt have to mess about putting the voulme up to 100% which is a PITA.
I havent got many DSD albums. So I have converted them to 24bit Flac files.

Problem solved :slight_smile:

1 Like

I trying to understand your position and be patient … but please understand mine - for over a week my system has not been working properly and I don’t even have an outline of a solution to the problem. As volumio is a commercial platform, it becomes natural to expect reliability - and here we have no compatibility lists, neither platforms nor peripherals; even if I wanted to replace Amanero with another USB converter, I don’t know which one, to be sure of correct operation (there is, for example, a U30 USB converter, but will it work?) … here’s what Amanero wrote back to me: "to install the native DSD endpoint on the Combo384SE there is this dedicated code firmware_2006be15r2_8804_TXRX and CPLD_1082_8804_TXRX. "- does which tell you something? We are talking about compatibility with Amanero, but you still do not answer me to the problem of crackles in the sound in vol.3 in both USB and I2S connections?

For me, and in version vol.3, the crackles are regardless of the screen settings and regardless of whether the DAC is connected via USB or I2S … there are no clicks in vol.2 … and indeed the DSD setting is inverted on vol.2 and vol.3, RPi3+ and RPi4 …