Syslog on Volumio ?



How do you get syslog working on volumio ? /var/log/messages and /var/log/syslog are always empty.

Long story :

I’m currently working on making usb dac hotplug work on volumio. It was it working fine on 1.4 but I just realized that 1.5 was out as I was writing a small guide to explain what I did. So I tried to make this work for 1.5 and it does not…
To debug this I need system logs (otherwise I cannot see why my udev rule fails) and i don’t find any. /usr/sbin/rsyslogd
is missing, log files stays empty … do you have any specific setup for development ?

thanks !

The logs are normally on /var/log

On Volumio, since there logs are on RAM, they are cleaned upon every reboot…

Often kernel level messages can be reported by ‘dmesg’. Let me know if this works for you.

@ning-yu : yes, I can see the dmesg logs (both with the command and directly in the corresponding /var/log file) but udev logs are not written here. From what I read they should be in /var/log/messages but this file stays empty.

@michelangelo : it’s not a problem that logs are cleared on reboot, I’m investigating hotplug issues with udev and I’d like to monitor the logs at run time, I don’t need logs from previous sessions. I see the logs in /var/log, but many files here are simply empty, especially messages, which is where udev should put it’s logs.

I’ve installed rsyslog with apt-get, but it is still not started automatically at boot. Any reason to have it not installed by default on Volumio ? If logs are in ram anyway, it should not hurt the sdcard to have rsyslog running.

Nevermind, Ive finally managed to get rsyslog and bootlog running, this should help me diagnose the udev issues.

As a side note, I think you’re using transientlog script to log in ram, but somehow the permission got wrong and the script is not runnable. Logs are definitely written on SD on both my 1.4 and 1.5 raspberry Volumio install.

I’ve simply ran “chmod +x /etc/init.d/transientlog” and after reboot everything is in ram as expected. Boot process seems to be much faster that way :slight_smile: especially for me with rsyslog and bootlog running !

transientlog on /var/log type tmpfs (rw,nosuid,nodev,noexec,relatime,size=16384k,mode=755)

I have the exact same problem. An transientog was also missing the +x.

I added the +x dir a reboot but nothing changed. No logging whatsoever.

The version I was using was 1.55. This was release months after this bug was reported.

There is no syslog. And the problem with transientlog seems to have been there for months.

Can anybody help me? I have no idea what could be the reason.

And I have never seen anything like that.

And I have tried many linux distros but I never had one where syslog is not working and errors in the logging system seem to get not fixed for months. I really regret installing volumio. But now I somehow want to stick with it.

Following fixed it for me (V 1.55):

sudo chmod +x /etc/init.d/transientlog
sudo apt-get install rsyslog
sudo apt-get install bootlogd

:arrow_right: reboot

On a second attempt I needed

sudo update-rc.d rsyslog remove
sudo update-rc.d rsyslog defaults

as well.