Synology NAS mounted, but no data in My Music

I was previously using Volulmio (an older version, not sure which rev) on a Pi 2 B+ with Hifiberry Digi and everything was working great. Recently bought Pi 3 and decided to upgrade to latest Volumio 2.001 and now cannot get my music library to show up.

Files are stored on a Synology DS215j. Have manged to mount shared “music” folder in the root of the synology using NFS (green tick under “mounted”).

With the drive mounted the My Music section shows 0 artists, 0 tracks, etc.

The Update and Rescan buttons appear to have no effect.

Have tried deleting all the “folder.jpg” image files based on some feedback from the forum.

Music files are predominantly FLAC format with a few high bit rate MP3’s thrown in.

Have approximately 3800 files so shouldn’t been any issue with too many files.

Have been trying all sorts of tweaks with network settings and NFS configuration but nothing has worked so far. Any advice would be greatly appreciated.

Check permissions on your music directory??

OK fixed, incorrect permission on source folder in NAS.

Knew it would be something stupid.


I have the same problem. Please give more information, what you have fixed.

Hello there,

I’m not able to mount my music folder stored on my Synology DS415play, too. I already checked all permissions, tried to add a new network drive under Volumio 2.001, played around with different settings but Volumio doesn’t mount the folders that I have set up for testing purposes (with just a couple of tracks in them). Theyre addressed like this: music/testing.
One of those folders got mounted, but I’m not able to do that again; it seems Volumio has it’s own head :unamused:
And no folder shows up on the “mounted folder” screen:

Has anyone of you an idea or hint what’s going wrong?

Thank you,
kind regards

I’m having a similar problem trying to access a shared folder from my Mac Mini. In order to mount the share, I need to ssh into my Pi and mount it manually:

mount -t cifs -o username=justin // /mnt/NAS/

After I enter my password, the mount point appears under “My Music”. I’ll just deal with this for now and add the mount point to /etc/fstab but there’s certainly something amiss here.

My goal is to (soon’ish) have all my media hosted from a Synology DS916+, but I’m still testing with my Mac Mini (which is currently running mpd that I acess with MPoD from my iPhone).

Anyone? Bueller?


also, this is what i see in /var/log/volumio.log when i try to connect to a share:

2016-11-01T23:57:52.834Z - info: No correspondence found in configuration for share music on IP

I put every Rights to at least read for the shared folder but the library still won’t build. Where can I look to see what problems I have. In volumio.log I couldn’t find anything useful.

Greetings homry

Do you think you can post your settings of your shared folder in case I forgot something?
It took me a while to get the nas mounted, but now I still can’t listen to my music cause the database won’t build. I would appreciate it very much.
Greetings homry

if you ssh into volumio and type:

$ mount

do you see the connection to your NAS? if not, then it’s not truly mounted, despite what the Volumio interface may lead you to think.

Yes, I see it. But when I try to have a look into the folder cd /mnt/NAS/my_folder I get a “permission denied” with the volumio user.

Dunno right now where I forgot to check box.
Greetings homry


now my collected observations:

  1. nfs share:

Volumio Shows the share as mounted in the GUI, it said “added new share…” and “updating database” (dunno exact words).
In /mnt/NAS there is a Folder called “test” (my Chosen Name) with d--------- 5 root root test with an old date, although I just did it now.
I cannot remove the share in the GUI (error message). I cannot delete the Folder with rm -r test . It gives me cannot remove .... read-only file system . When I use sudo rm -r test , it tells me the same but for every file in my Collection over and over again. So, there is something…
In “volumio.log” it says: No correspondence found in configuration for share test on IP 192.168.1.xx
I set up the mountings over the GUI with both, with and without the NAS’s username and passwd.

  1. cifs share:

Volumio creates a Folder drwxr-xr-x 2 volumio volumio test with today’s date, but the message No correspondence found in configuration for share test2 on IP 192.168.1.xx info: Error mounting test2 on IP 192.168.1.xx : (22): Invalid argument Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

Maybe someone has an idea.

Greetings homry


now I tried to Mount the share manually either with nfs or with cifs:

mount -t cifs -o username=homry //192.168.1.xx/Audio /mnt/NAS

gives me

mount error(13): Permission denied
mount -t nfs -o username=homry //192.168.1.xx/volume1/Audio /mnt/NAS

gives me

mount.nfs: remote share not in 'host:dir' format

With cifs it still seems to be a permissions Problem, but honestly I do not know where to apply more rights on my nas, because I already gave every user on the nas read/write. Do I need a special user with use with volumio?
With nfs I totally do not know what that means.

Greetings homry

mount -t cifs -o username=homry //192.168.1.xx/Audio /mnt/NAS

Works now with the “advances share permissions” enabled on the NAS shared Folder.

Also the databse builds up now , but the mount over the GUI still does not work (wrong Argument…).
Maybe I should add something as Argument over the Options field?
Alternative would be to edit /etc/fstab which wouldnt be so nice.

Any suggestions?

Greetings homry


an automatic Mount via /etc/fstab does not work, most probably because the nas is not always avaiable at once but more in a sleep mode. It takes some seconds until it is running and additionally the Network Connection might not be established at that time fstab is used. For the last Problem there are various suggestions to solve it, but the sleeping mode of the nas? It takes up to 10 seconds until it is running.

Are there anny ideas? How is volumio itself doing it, when a NAS is configured? A Mount -a should work, but manually doing this is not my Goal.
And still there is the question why the cifs mounting will work manually, but not over the GUI?

Greetings homry

Mount - a in rc.local
With sleep 20
because you have to wait till network is on

thanks for all your help.
It is working now, but only with some tweaks which I would like to share for those who still might have some similar Problems.

  1. editing /etc/fstab with direct mentioning of user and passwd never worked (Mount error, invalid Argument). It worked without Problems via .smbcredentials.

  2. sleep 20 was not enough. It only worked with at least 60 (raspberry pi, edimax usb-wlan-stick).

greetings homry

With regard to your problem with NFS, it doesn’t require either a username or password to mount a NFS share. Simply the correct permissions need to be set on the NAS to allow your volumio client access to it.

I think I have i similar problem. My volumio2 runs on an RPi3. My music collection ist stored on an OMV NAS. There is an folder named “iTunes” within all music is. I have configured a share with nfs. Now I can mount share on volumio webpage, an the green tick is shown. But no music is shown. If I use ssh terminal, mounting ist ok. With user volumio, I can open the share and see all my music. If i use shell cmd “service mpd status”, there is an permission denied error. What is wrong in my configuration?