Switching Volumio to use a different IP subnet

I could have swore I posted this but somehow it didn’t make it. I pulled a Volumio out of an event space to do some diagnostics. It’s running on an RPI3B I’m trying to bring it up on my home network. Problem is, it was set up with static IP, and the event space uses a different IP subnet than my home network. I tried changing the eth0 config by editing /etc/networking/interfaces and explicitly trying to set it up with a static IP on my network, giving it my gateway, then rebooting. It always comes back stuck at the same original static IP. It almost seems that once you set the IP up statically through the web UI, you cannot alter it except through the web UI. Is there a back door around this? I’d really like to run diagnostics on this Pi at home rather than have to lug my laptop to the event space.

Answering my own question here. I’m not sure how this worked, but I edited the /etc/network/interfaces again, and played around, I went with
iface eth0 inet static
address 192.168.x.y
gateway 192.168.x.1

(for any newbies, substitute x for the number of your subnet. Your typical DSL or Cable modem router probably gives you a subnet like 192.168.0. or 192.168.2., and y is a number between 2 and 254 you want to use for the final octect in your IP).

I then did sudo systemctl restart networking.service
then sudo systemctl reload-daemon
then I rebooted. Much to my surprise, this time it actually came up on the right subnet. I was then able to change it to DHCP manually.