Suddenly can't get any music to play

After a week or so of no trouble, Volumio has just stopped playing any music. I can access the gui with no problem and see all my files, but trying to add and play doesn’t work. I tried NAS and Web radio. They go to the playlist but the counter doesn’t move off 0:00. Did the same with Streambels on Android and exactly the same issue.

I’ve tried rebooting and also a full shutdown and restart but it’s just the same. I don’t know what else to try?

What hardware are you using? Raspberry PI or something else?
What DAC do you use? Internal or External (USB)?
Did you try just remounting the NAS drive (go to library and reselect it?) - that will force an update of the library.
In case it would give a red cross with the mount an complaining about a mountpoint, you need to add it:

login through ssh (putty) as root with password volumio

cd /
cd mnt
mkdir NAS
chmod -R 7777 /mnt/NAS

Then you can remount it in Volumio front-end.
Hope this helps!

Please show us the result of

df -h

Is there no space left on the the sd-card?

Hi,
it seems that I have a similar problem. I have still access to WebUI, as well as control of everything by MPDroid or sound@home, but I cannot listen to music. I’m not using a NAS, my music library is on a USB drive. Restarting MPD server or rebooting the Pi does not help. I can add music to the playlist, but like LeChuck described the time still remains at 0:00. Sometimes the music starts even “playing”, what means the time moves forwards but it plays at 0 kbps (-> no sound).
The only thing what helped, was setting everything up again, but with 1.2beta it worked only for a few hours until the problem occurred again.
I’m using a Pi (Mod B) with a PCM 2704 based DAC. I’m not sure but may it be related to insufficient power supply? When I unplug the DAC and restart the Pi it seems, that everything is working with the output of the 3.5 jack.

Edit:
The size of the SD cards I tested was 4 and 8 GB

I would also say that is a problem with audio output.

A unsufficient power supply is a good idea.
Maybe you could try the audio jack over hours to see if the problem occurs again?

Tobbes

I’ve decided to start again and install 1.2, my issue was on 1.1

My USB DAC got delivered today so I’ll be trying to use that. Previously it was just 3.5mm jack connection.

When I mounted my NAS I had to mount it by using putty, doing “sudo apt-get update”, “sudo apt-get install cifs-utils” then “sudo mount.cifs …” because it wouldn’t work through the GUI.

I should add exactly the same thing happened with .pls files from webradio, which should be unaffected by NAS mounting?

If I have problems I’ll report back.

Sounds exactly like what was happening to me, I omitted some of the details you posted but they all happened to me as well, although it was all through the 3.5mm as I didn’t have a DAC connected.

Ok, so it’s still happening. Tried mounting the drive again but that doesn’t help. Again, no webradio working either.

This is the result of “df -h”.

volumio@volumio:/mnt$ df -h Filesystem Size Used Avail Use% Mounted on rootfs 1.5G 900M 522M 64% / /dev/root 1.5G 900M 522M 64% / devtmpfs 235M 0 235M 0% /dev tmpfs 49M 1.3M 48M 3% /run tmpfs 5.0M 0 5.0M 0% /run/lock tmpfs 256M 0 256M 0% /run/shm /dev/mmcblk0p1 75M 19M 56M 25% /boot Ramdisk 256M 0 256M 0% /run/shm

Edit: For some reason it’s working again now. :confused:

Same issue here. Please help!

Using UDOO board through a 3.5 jack. Music shows in the playlist but it does not play (only shows “0.00”). Music library is in USB and there is no NAS.

Doing a df -h, this is what it shows:

root@volumio:~# df -h
Filesystem Size Used Avail Use% Mounted on
rootfs 1.2G 591M 545M 53% /
/dev/root 1.2G 591M 545M 53% /
devtmpfs 438M 0 438M 0% /dev
tmpfs 88M 1.3M 87M 2% /run
tmpfs 5.0M 0 5.0M 0% /run/lock
/dev/sda1 58G 11G 47G 19% /mnt/USB
tmpfs 512M 0 512M 0% /run/shm
Ramdisk 512M 0 512M 0% /run/shm

Any help would be much appreciated!

THKS

Anyone? Please help.

Bump! Please help here!

Quick and dirty fix…

Try 2 things:

1- update browser page with ctrl+f5

2- try to restart mpd with

sudo /etc/init.d/mpd restart

from ssh

let me know

(now using mpd 18.9, seems really stable… will include in next release and think this will be a huge step forward…)

Is it easy to manually update the current release to 18.9?

I’ve found that setting a crontab job to run “sudo /etc/init.d/mpd restart” every night keeps things more stable too.

i have posted my version here, hope it helps
http://volumio.org/forum/optimize-compiler-flags-for-mpd-t507.html#p3175