Still no volume control on Pi Zero, even with v2.777?

Volumio Information

Volumio Version: v2.777
Hardware: Pi Zero
DAC: JustBoom

Was hopeful that this would be fixed when I saw the notes for v2.777, but on my Radio Pi the volume controls still don’t seem to work?

I use it as a web radio streaming from the internet, and if I try and change volume either via the web interface or from a python script/JSON almost nothing happens. If I move between 100% and 95% volume I do hear a small change, but anything below 90% just outputs at 95% and mute/unmute doesn’t do anything still.

Is there anything that needs to be done in the DAC settings to get this to work, or any logs etc I could provide to help get this resolved on my hardware combination?

OK having looked into it, I’ve found the problem.

The settings after the last upgrade seem to have flipped over from a JustBoom DAC to a HifiBerry one. Putting that back to a JustBoom and rebooting has fixed it. Volume controls now working correctly…