Static IP address not registering

Win10, PI 2B, Volumio 2.348

Everything up and running on an automatic ip but I wanted to move to a Static one.
I have tried this twice and in both cases it has gone missing, no sign of it when I scan my network.
The first time it happened I removed the sd card and rebuilt it, not a lot of fun!

Will I have to do this again or is there another way, like editing a configuration file?


Unfortunately this is a recurring problem. There have been releases in which this did not work at all.
I have today changed the static IP (network houskeeping) - then no connection came back, neither under the old nor under the new IP.
As the old saying goes, every boot is doing well - after that volumio was again reachable under the new IP.
So: power out, wait, power in


Black Senator

Thanks for reply.
I have actually powered down and removed the card, replacing it with an older configured version of Volumio.
I will try replacing the new one and see if it has taken the static IP.

If it doesn’t I thought to use PuTTY and a hardwire connection to edit the network file, but which file, where?


I have spent a lot of time in the past fiddling with this, and eventually gave up in favour of getting my router to assign a fixed IP address to my various devices. I have not tried to set it up via Volumio for a good while, so am not able to comment on how well this works or doesn’t in the current versions. Configuration file setup of static IP addresses was deprecated some time ago in Raspbian (although there are many posts on the internet referring to this) & you would be advised to leave this well alone.

If you want to investigate the problem further, you will need to attach a keyboard and monitor to your device & check system logs (journalctl) and assigned IP addresses (ifconfig and iwconfig).

I am pleased to say that putting the new SD card back in and powering up my connection was restored on the Static IP.
However ‘fixing’ the IP in the router sounds a good idea, so I will also do that.