Start of selected song cut off

When I start a song it starts a split second into the song. If I press the skip back button it starts perfectly, or if a song ends the next in the queue starts just fine too. It’s only when I manually start one.

The files are on a NAS steamed over wifi. I’ve changed the prebuffer to 30% and 12MB and it hasn’t changed anything.

Is this normal behaviour?

Unfortunately it is, at least in my experience. (Files stored locally on a memory stick in my case).

Thanks for the reply.

That isn’t ideal. Playing a song from the start is a minimum requirement in my opinion.

Can you please share more info about your setup? DAC?

I’m using a pi2 with HDMI audio out, going into an AV receiver.

Playing FLAC files (it’s the same with mp3) from a NAS over wifi.

Do you select your tracks from “Music Servers” or did you mount your NAS from my music?

If its the first option, then probably the issue is that your AV receiver unlocks the signal when there is a track change.
Can you please confirm?

My NAS is mounted and the music is all in my library. I choose songs from the ‘albums’ section on the Volumio app. The person above said that they have the same issue when using USB media

Same issue. Rpi 3, local usb FLAC and mp3 files, HDMI out to receiver. Any ideas?

Firstly, sorry for my poor English… :wink:

I am new to Volumio, where I have just upgraded myself from Chromcast audio… Unfortunately I am now having exactly the same issue as above.

I am using:
Volumio version 2.526 (latest)
Allo digione - using coaxial output
DAC: Audiolab MDAC+

It appeared that the ‘cut off’ during the first few second of the song is causing by the PCM ‘switch off’ and on between tracks. It doesn’t matter if I am using the nas, or USB… and it is even a a bigger issue if using the Spotify connect, as it happened to every single track!

You can observe the symptom by monitoring the DAC display (if it have a one) where it will become ‘unlock’ , and ‘will lock’ again after the song has been started for a few seconds, which essentially causing this ‘cut off’.

Apparently this is an old issue, as I have done some research and discovered a couple of discussions with the same problem. A few people have already requested for a fix or looking for an alternative solution:

 [always-pcm-signal-dac-t2159.html](https://volumio.org/forum/always-pcm-signal-dac-t2159.html)

 [github.com/volumio/Volumio2/issues/1668](https://github.com/volumio/Volumio2/issues/1668)

I would suggested that this can be fix if there is a way to make the volumio to keep the PCM connection to become ‘always on’.

I have done some experience by switching back to use the Chromecast audio (with Toslink), and have observed that the Chromecast audio did actually keep the PCM connection always on, hence this issue never happen.

Further more, I have done a control experiment by using a CD player with coaxial to drive the Audiolab MDAC+, and appeared that it did not ‘switch off’ the PCM connection between tracks… This experiment proven that it is not cause by the difference between Coaxial and Toslink.

Clearly I am not the only one who suffered from this issue, and I would like to know if Volumio can help us to resolve this problem?

Or perhaps to provide a ‘PCM always on’ or ‘keep PCM connection’ option in the setting so that the user can select based on they system requirement?

Many thanks. :slight_smile:

I just got Volumio running today. I’m encountering the same problem.

Raspberry Pi 3 B+, JustBoom Digi, optical out to a Harman Kardon receiver. Playing 24/96 .flac files from a thumb drive.

The display on the receiver reports that it is unlocking.

This didn’t happen when playing the same files with VLC on my 2010 MacBook, optical out.

And just to echo GaryC, Spotify Connect is basically unusable. The first two seconds of every track are cut off, whether playing whole albums & playlists, or picking out individual tracks.

Again, this was not an issue using the optical audio out on a 2010 MacBook, using neither the Spotify desktop app, nor the Spotify web player.

Dan

This is a long-time issue, we’re still trying to find a working approach for this…

For better or for worse, my 2002 Harman Kardon amp died. I replaced it with a 2009 Harman Kardon amp. The problem desists.

Dan