Spurious Volumio behaviour wit Hifiberry DAC2 PRO

Hi all,
Since 2 Weeks I own a Hifiberry DAC2 PRO HAT for my 4GB Raspberry Pi 4. Since then I’m struggeling to get it work with Volumio. I dont have the 7’’ display or the like attached. Unfortunately the behaviour of the System is unpredictable. When it works, I’m really enthusiastic with the nice interface ,the possibility to insert podcasts (I use the system exclusively for webradio) and the good quality of the sound.
Unfortunately always when I turn the System off and restart later the next day i get the ALSA device “hw: 2.0” not found error reported many times in this forum. When it is not working I notice that the green LED on the DAC2 PRO is not lit. When I turn I2S DAC off Restart the system turn I2S on again and repeat this procedure an unpredictable number of times I see the led lit during startup and then the system works normally. I spent several days an nights on this problem now and tried out the advice given in the net, I commented “dtparam=audio=on” out and set dtoverlay=hifiberry-dacplus (Tried dacpluspro as well) and it works with this configuration. However when I turn the system off and then on again later, the trouble starts always again.

Hi Karl,

are you on the latest version 2.861 ?
For me this is working flawless with this DAC, without any manual editing files

br
Josef

Have you tried re-seating the Hat, possibly using a bit of contact spray too?

@JoachimStrobel

these contacts are gold plated - so i would not recommend contact spray (at least not any kind of).

i‘d bet this can be solved on the software side

br
Josef

Hi Josh2000 and JoachimStrobel, Thanks for answering. I use the latest Volumio Version 2.861.
I re-seated the HAT several times but have not tried with contact Spray.This morning, after having turned the System off for the night, I again could get it working only after doing the cycle “turn I2S to Off, reboot, set i2S to on (DAC Model to DAC Plus) reboot” 6 times . During the first trials the green LED was always off.

This definitely sounds like a hardware/contact issue rather than a software issue. The green light on the DAC should come on to indicate that it has power, and I don’t think that there’s a way to disable that in software…

What power supply are you using? It’s possible that the Pi 4 is drawing more current than your PSU can reliably supply.

Hi timothyjward,
Thank you for answering. I’m using the official Raspberry Pi USB-C Power supply. I will get me some contact spray today. It is strange though. My DAC lives in the the official Hifiberry box. When I turn it off, it sits there the whole night without being touched or moved. It happens also , like this morning that, after I turn it on, the LED is lit and I get “Failed to open Alsa device…” nonetheless.

I had similar issues with a DAC2HD and an Amp2. Both issues went away, but they were strange. In one case I had used a raiser to mount a fan below the HAT to cool the CPU. I removed the raiser and all worked well from then on.
Hifiberry suggested it is Volumio „forgetting“ the device or the Raspi. Lesson learnt for me: Always order via Amazon Prime and send the stuff back if it does not work. In the EU it is close to impossible to return anything to Hifiberry as they are non-EU.
Turning this around: Get a new Raspi4 and check if the problem persists, if yes, then return it and search elsewhere. Same goes with the HAT. If that does not help it has to be Volumio…

Hi all, In the meantime I continued the tests.
I purchased a second DAC2 PRO to be sure. I own several Raspis. I tried different combinations and also applied contact spray. Moreover I flashed a fresh SD card. The random “ALSA device not found” problem persists.
With enough patience and several reboots and turning off and on “I2S DAC” a few times, I always succeed in getting the the system to work though sometimes it works right away. However as I want to give the box as a gift to my mother, I would not like her to fiddle around with reboots.
I saw other behavior which I don’t think to be normal.
Sometimes I notice that there is output signal at the cinch connectors even when I2S DAC is turned off.
Sometimes after the system has been turned on I can’t change the amplitude of the output.
Simply pressing “SAVE” in the general options/Audio output options without changing the state of “I2S DAC” and “DAC Model” fixes this in most cases.
Sometimes, even when turn off volumio in the interface with Mixer Type set to “Hardware” and Mixer Name set to “Digital”, when I turn it on again Mixer Type is set to “None” or “Software” and the name to “Analog” without me changing anything. (I’m using the Italian version of the interface, therefore my translation into English might not correspond exactly to the reading on your interface ;-))
kind regards
karl

This is really strange, it works for me. Finally, you could try another Hifiberry DAC and see if that has the same problem.
May it is the language? Kind of do not believe myself, but may you should install Volumio in English? And btw, if you never turn it off it works?

I had the same issue, fully working when I configure I2S, after reboot same error.
I found that post talking about editing the confi.txt file and remove the last line with overlay comand.
After that the sistem works good also after reboot, the volume is a bit lower but nerver mind.
To restore the volume control in settings->playback select the mixer type and the volume controll is restored, not completely (at 0 is not mute) but you a bit of controll.
I tried reboot several time without issues.

I think it’s a driver issue because there is no available dedicated DAC2PRO driver instead of DAC+Pro.
I hope the compatibility will be added soon to use full power of the DAC2PRO.

Hi All,

Coming late to this but I have a similar problem. I have just installed the latest Volumio build on a Pi 4 with the Hifiberry DAC2 Pro. The only way I have been able to get it to work is to set I2S to “No” with the DAC as Hifiberry DAC. This results in a green light from the DAC when I play a track and sound from the RCA outputs. In this configuration the Volumio volume control does not work. If I enable I2S then no green light and alsa “failed to open errors” or Volumio tries to play but the track but the counter doesn’t move. It doesn’t make any difference which of the Hifiberry drivers is selected.

There seem to be a number of threads on this topic including on the Hifiberry site but no definitive resolution. I haven’t yet tried the force_eeprom_read=0 proposal which seems to be linked to the Linux kernal version.

Based on the behaviour I have seen since flashing the card with Volumio the hardware all looks fine and this appears firmly to be a software issue.

On a more positive note the sound coming out of the Pi + DAC combination was impressive on a first listen via some Temple Audio amps into Quad ESL 63s. I also have a Volumio Primo but haven’t done a side-by-side comparison.

Kind regards,

Tom

Hi Tom, I fiddled around with the problem for weeks. BREX posted the solution that works for me and others.:

Solved!

I think there are 2 different issues that are easy to confuse:

1- the headphones jack cannot work in Volumio, SOLUTION: buy a 4€ RCA to jack adapter on Amazon, end of the story.

2- the DAC2Pro with Volumio after reboot doesn’t work anymore with "Alsa HW 2.0" error, SOLUTION: after the first configuration with everything working fine, switch off the pi, edit config.txt and insert command.

force_eeprom_read=0 restart the pi3.

I have a pi3 with DAC2Pro and in that condition finally everything works fine: jingle at boot, the led on the DCA2Pro turn on when playback, volyme control works, now it’s perfect!

Hi BREX,
I proceeded like you state in the 2nd point of your post. Actually I first was a little puzzled of how should I edit the “config.txt” file after having switched off the Pi ;-))). So I Inserted force_eeprom_read=0 before turning off and restarting the Pi. Now also for me the system works and I can control the volume. Actually I had used force_eeprom_read=0 already in earlier trials with no avail. So it seems to be important to do this immediately after the first configuration
Thank you very much, my nightmare seems to be over.
Karl

Hi Karl,

Many thanks for the reply. I edited config.txt to add the line, changed the playback settings to I2S with the DAC+ Pro driver, rebooted and it worked. No errors and the volume control was restored.

I got away without needing to reflash the card.

Cheers,

Tom