Spotify will not load

I am running Volumio V2.7.29 on pi 3B.
I can load the Spotify V2.0.2 plugin and authorize its use (my Spotify premium account shows Volumio has access).
Spotify appears but when I click it nothing happens. The loading progress bar stops almost at the end.
I have re-installed Spotify several times and re-flashed Volumio and used different SD cards but always the same issue.
Can anyone help?

Can you post your log file. /var/log/volumio.log

The log file shows that the certificate is not yet authorised - after several hours!
2020-03-18T00:38:08.710Z - info: An error occurred while refreshing Spotify Token Error: certificate is not yet valid
2020-03-18T00:38:08.753Z - info: An error occurred while listing Spotify featured playlists WebapiError: Unauthorized
2020-03-18T00:38:08.773Z - info: An error occurred while listing Spotify categories WebapiError: Unauthorized
2020-03-18T00:38:08.777Z - info: An error occurred while listing Spotify new albums WebapiError: Unauthorized
2020-03-18T00:38:11.194Z - info: Fetching Streaming Services browse cache
2020-03-18T00:38:11.403Z - info: CoreCommandRouter::volumioRemoveToBrowseSourcesQOBUZ
2020-03-18T00:38:11.405Z - info: CoreCommandRouter::executeOnPlugin: my_music , getDisabledSources
2020-03-18T00:38:11.419Z - info: CoreCommandRouter::volumioRemoveToBrowseSourcesTIDAL
2020-03-18T00:38:11.420Z - info: CoreCommandRouter::executeOnPlugin: my_music , getDisabledSources
2020-03-18T00:38:26.257Z - info: CoreCommandRouter::executeOnPlugin: system , getSystemVersion
2020-03-18T00:38:26.258Z - info: CoreCommandRouter::executeOnPlugin: system , getConfigParam
2020-03-18T00:38:29.747Z - info: CoreCommandRouter::volumioGetState
2020-03-18T00:38:29.747Z - info: CoreStateMachine::getState
2020-03-18T00:38:29.747Z - info: CorePlayQueue::getTrack 0
2020-03-18T00:38:29.811Z - info: CoreCommandRouter::volumioGetQueue
2020-03-18T00:38:29.811Z - info: CoreStateMachine::getQueue
2020-03-18T00:38:29.812Z - info: CorePlayQueue::getQueue
2020-03-18T00:38:29.813Z - info: CoreCommandRouter::executeOnPlugin: system , getHwuuid
2020-03-18T00:38:32.748Z - info: CALLMETHOD: system_controller system enableSSH true
2020-03-18T00:38:32.749Z - info: CoreCommandRouter::executeOnPlugin: system , enableSSH
2020-03-18T00:38:34.416Z - info: enable SSH service success
2020-03-18T00:38:34.424Z - info: CALLMETHOD: system_controller system enableSSH true
2020-03-18T00:38:34.428Z - info: CoreCommandRouter::executeOnPlugin: system , enableSSH
2020-03-18T00:38:36.612Z - info: enable SSH service success
any advice?

Strange, I haven’t seen that exact message before. I would try to reauthenticate your account in the plug-in. Not sure what else to advise. I’m on the same release and it’s working fine for me on two different Pis.

Thanks for taking the trouble to look at the issue. No luck with the re-authorization. I will try a new install.

Solved: It is a problem between Spotify and my ISP. When I connected via my mobile as a hotspot the Spotify plugin worked perfectly.

Awesome! Glad it worked out.

Spoke too soon.

I had to re-install Volumio and lost Spotify. The log details are as before with a message that it is still waiting for authentication.
Looking at my Spotify account I can see that Volumio app has access. Neither Spotify nor my ISP provider can help. Is there anyone in Sweden connected to Spotify via Volumio?

Really would like to stick with Volumio as it has the best UI and has unsurpassed source and playback options.

Solution is to ensure the time and date are correctly set in raspberry pi

ssh and use cmd “sudo timedatectl set-ntp True”