Spotify Podcasts only playable with annoying trick

Hi all,
I am a big fan of Volumio and use it often and for a few months now. Mostly in connection with spotify. However, a few things have been annoying me a bit and maybe you guys have had same issues and could help.

When playing spotify podcasts i can’t stream them directly to volumio as I usually can do with music when I started a song on another device. I have a workaround where I start a song (thereby starting playback) and then I can start a podcast. But if I pause and wait too long i can’t load into it again and have to use the same workaround all over again.

Also is there a way to make my volumio restart like every 12 hours since it sometimes hangs itself and I have to manually restart.

Volumio Information

Volumio Version:2.873
Hardware: Raspberry Pi 2 Model B
DAC:

Hi senorkulo, welcome to Volumio. :slight_smile:

Firstly, I don’t use Spotify for podcasts, but are you talking about the Spotify or Spotify Connect plugin? What happens when you try to play a podcast?

In terms of restarting Volumio on a regular basis, you can either use cron to run a script at a set time, or use systemd timers (have a Google) … alternatively, there is a thread here.

Okay. The podcast issue has finally stopped. I updated my OS and it didn’t work right away but now it does. I use Spotify Connect now as well. Not really sure what the difference is. Thanks for the Reply!

Thanks for the reboot trick! I am going to see how the up time is with the new update. Wish they would integrate it in settings though.