Spotify Plugin on BBB - spopd crashing

Hi All

Fresh Volumio 2 install on a BBB from the current image, local music plays OK, install of the Spotify plugin appears to work fine.

I update my Spotify settings and volumio.log reports it authenticates OK. I can see my Spotify options (What’s New, Playlists etc.) so it has authenticated but no music will stream as my spopd process has crashed.

If you save your Spotify settings, spopd is restarted but stays up for less than a minute. This occurs with nothing else happening on the BBB (no music playing etc) . volumio.log shows the entries below.

2017-02-21T04:24:38.642Z - info: [{“prettyName”:“Spotify”,“name”:“spop”,“category”:“music_service”,“version”:“1.2.0”,“icon”:“fa-spotify”,“enabled”:true,“active”:true}]
2017-02-21T04:24:40.598Z - info: CoreCommandRouter::getUIConfigOnPlugin
2017-02-21T04:24:42.687Z - info: CALLMETHOD: music_service spop saveSpotifyAccount [object Object]
2017-02-21T04:24:42.691Z - info: CoreCommandRouter::executeOnPlugin: spop , saveSpotifyAccount
2017-02-21T04:24:42.952Z - info: SpopD Daemon Started
2017-02-21T04:24:47.960Z - info: Connecting to daemon
2017-02-21T04:24:48.024Z - info: CoreCommandRouter::volumioAddToBrowseSources[object Object]
2017-02-21T04:24:48.028Z - info: [1487651088024] CoreMusicLibrary::Adding element Spotify
2017-02-21T04:24:48.058Z - info: FIRST BRANCH
2017-02-21T04:24:57.360Z - info: Spotify access token expires at 1487654687967
2017-02-21T04:24:57.364Z - info: Spotify access token is BQBvhazVw0HqBDYmn0eAsCg6dL4XQ2uNzLMK7CvTRYMXDdZgiXNDYuwCmmLwRt4-gXq3Escb9fWY9Qf025uj5w
2017-02-21T04:24:57.368Z - info: Spotify credentials grant success

There doesn’t appear to be an spopd.log file that I can find.

Any ideas on what to do next? Happy to assist with whatever is required.

Thank you for this great project.


OK. I have runup Volumio on a Pi 1 and I am experiencing the same issue. Now I’m confused!


I had troubles with spop too on single core boards, admittedly I only tested on the PiB and PiB+, but the BBB doesn’t have much better specs.
My findings were posted here: spotify-plugin-spop-becomes-unresponsive-command-error-t5044.html

You could try to run ‘sudo journalctl -f’ over SSH and fiddle a bit with the Spotify plugin. I think the board takes too long to process requests/responses and runs into timeouts or miscommunications.

Hi Saiyato

I have tried running Spotify with Volumio in the past and have always encountered weirdness. I’m thinking you’ve provided an explanation for the weirdness - thank you! The BBB is is roughly the performance level of a pi 1 B+ so this tallies with your experience.

So, it looks like Spotify can’t be used with single core boards, I’ll try to change the Subject to Solved if I can.

Thank you for your help.