Spotify plugin - latest system update

Hi guys, strange thing happend to me after last update to 2.555.
Looks like Spotify plugin decided to die. I can access generes / playlists without problem and i can’t enter to playlist, so when i’m trying to clear and play or just play the playlist - nothing happens. Did Spotify decided to kill API or something? :imp:


Same for me, logs do not show anything special (“info: CoreCommandRouter::executeOnPlugin: spop , handleBrowseUri”)

I tried a refreshed token, update of Connect2 plugin, update of Volumio -> no difference

Somethimg changed in the spotify API code … list-uris/

Verzonden vanaf mijn iPad met Tapatalk

Take a look here … this has all been solved in version 0.8.6.
pay attention this is volspotconnect2 version 0.8.6.

you can also install an older version … it also works. … /

Guys, but this is not about spot2connect plugin. It is about Spotify plugin. So far spot2connect works well, but i don’t want to use my phone to run additional spotify app on it. I just feel more comfortable with plugin on my Volumio system.

BTW i have build my car audio on older version of Volumio (2.45 i belive) and Spotify plugin works ok there.

So question is if changes in 2.55 could mess up with it? Or Spotify plugin need to be rewrited for new API needs?

What do you think?


I have experienced the same issue.
Most of the Spotify lists doesn’t works. If I search for particular track it’s found and playable.
This behavior was present before and after 2.555 update.

Is there anything that I can do to get this fixed? I am willing to donate some money or my skills to help solve this problem. Please let me know if this can be fixed.

Same here. Spotify plugin 1.3.5, system version 2.599

  1. Spotify playlists can be found but cannot be added to the queue and do not play.
  2. Some tracks can be found and, if found, do play. But many tracks and albums do not appear in the search results. Example album:
    Thank you for your help!

You will need to patch the plugin per these instructions:


This will get you up and running:


Yes, this works. Thank you!

Spotify plugin not working for me. Plain Raspberry Pi3+, etched last 2.618 on new MicroSD, basic config and then trying spotify plugin without success, spotify icon not appearing at all.

Found this thread, tried this solution and same result, Spotify plugin not shown so can’t access Spotify.

Own several raspberry PI3+ with older volumios and older Spotify solution where you also obtain the oAuth code and then replace the index file in the plugin and put the code and they work ok. But this new version seems to have something wrong with the Spotify plugin…

Can you post your log file - /var/log/volumio.log

I just upgraded to 2.619 and all is fine here.


I apologize for my mistake! After some tests I discovered that my Spotify account was weird as it let me login via browser (Firefox or course) and refuses to log in via app…

I’s a family account and someone changed the address of the main account and the rest of the family accounts went toa weird state. I redid everything at the premium family level, etched a new SD with the latest Volumio (2.632), install the plugin with the new intructions at, put my username, password and Refresh Token in place and Voilá!

Working like a charm!