Spotify: Playback too fast

Hi all

First of all congratulations for this great project!

My setup is volumio on a RaspberryPi3:
Linux volumio 4.4.9-v7+ #884 SMP Fri May 6 17:28:59 BST 2016 armv7l GNU/Linux

My soundcard is the following:
card 5: Aureon51MkII [Aureon5.1MkII], device 0: USB Audio [USB Audio]

As output I used the analog (cinch) and SPDIF.

My problem is, that spotify plugin plays any song too fast.
I checked it with a “Amy Winehouse, Back to black” which has a duration of 4’.

  1. The piece plays only 3’40" when using the spotify plugin. On the display it shows the correct 4’ as total amount of time
  2. Playing the piece over AirPlay/Volumio works fine, the piece takes the correct 4’

The relation 4’ (240") to 3’40" (220") is similar as the relation of the two sampling rates 48kHz/44.1kHz.
Probably the problem may be found in this area. The assumption is, that spotify plays song with a sampling rate of 44.1kHz and the spotify plugin plays them with 48kHz.

Has anybody else made the same experience?
Is there any possible solution around?

Thanks in advace!

Best regards
Roland

Hi all

Has nobody else the same problem with spotify?

Best regards

Hello

I still have the problem, that playback from Spotify plays too fast.
In the meantime I have made some further investigations:

  1. My sound card plays only with 48kHz sampling frequency
  2. Playback via MPD, Spotify-Connect, Youtube works find.

The problem seams really, that the bitstream from Spotify (44.1kHz) is played back with 48kHz.
I made the following hack:
I corrected the sampling frequency again by the factor 48/44.1 which results in 52.254.kHz
With this correction works fine!!

[codepen]
volumio@volumio:/etc$ more spopd.conf
[spop]
spotify_username =
spotify_password =

high_bitrate = true
audio_output = sox
pretty_json = true
search_results = 50
cache_path =/run/shm

[sox]
output_type = alsa
output_name = hw:5
effects = rate -v 52245
[/codepen]

Has anybody an idea how to correct this problem in a proper way.
Which means e.g. configurring sopped or alsa accordingly?

Many thanks in advance.

Best regards
Roland

1 Like

Hi,
I have exactly the same problem, the same hw and sw config
Maybe you have it fixed, let me know.

I will investigate it too.

Regards,

Tcmdg

Just to add - exact same issue on my fresh install (x86 platform), spotify sounded like a chipmunks episode but other sources were fine,

Resolved by:

  1. Enabling SSH via the /dev/ addition to URL
  2. SSH into Volumio and edited the file /etc/spopd.conf and added the line:

effects = rate -v 52245

Saved, restarted and all fixed, sounding great

Thanks for the advise by the original poster, surprised this is still an issue 3 years later but hopefully others will find this bug report when the search for volumio + spotify + fast

Hello everyone!

Thanks to roland68 for the solution!
I am writing because, in my experience, this phenomenon only affects SPOTIFY playback.
I use VOLUMIO PI Zero and PI 4 and only cause fast playback when using SPOTIFY and only for USB “DAC” (SB wireless USB).
Is SPOTIFY allergic to USB DAC?
I reinstalled it several times, read a lot, tried a lot, but this is the only fair and good solution to the fast play phenomenon on my system.
VOLUMIO plays the radio well, local MP3. FLAC, etc. files, TIDAL, but Spotify is fast.
Thanks again for the correct solution!