Spotify on RP 3 not working

Hey all,

Spotify wont play for me on my device.

Initially I assumed it was because I didn’t have a DAC so I went and bought a HifiBerry DAC+… still no luck.

Here is my setup:

Raspberry Pi 3
HifiBerry DAC+
Volumio 2.041
Spotify Premium Account

Web radio will play fine. When I do click over to spotify, I’m able to slowly navigate through their library, when I click play on a song I get a message stating that my song is playing but web radio continues to play. My playback window will not show whatever I selected via spotify only a popup message stating that I began playing my selection. On the playback window visually, on the left status ring, “webradio” will continue to show.

I’m not sure what I’m missing, or what I did wrong. Any tips would be greatly appreciated.

Try using Clear and Play from the drop down menu on the track wanted. Web radio seems to keep quite a grip on playback and won’t stop.

I gave up using Volumio 2 purely for this reason, Spotify worked fine sometimes but at others it just didn’t. I also had to continually go to settings and deactivate the plugin and then reactivate it to get it to work.

Unfortunately the Spotify plugin is too unstable and doesn’t give full use either, once it’s fully functional I’ll try it again.

Not sure, but is this something to do with the software mixer? I don’t think that the Spotify plugin works with this (see note in plugins), and I believe that the Hifiberry DAC+ doesn’t have a hardware mixer??

I think that you need to justify this statement. Personally, I don’t find the plugin to be unstable at all. In what way “doesn’t it give full use?”

Same issue here.

Radio play’s without a problem, but when i want to play a spotify playlist the menu isn’t responding correctly.

1 out of 5 attemps spotify will work. 4 of 5 times i can click on spotify, but cant sellect anything after that.

When i say unstable, I mean it doesn’t run every time I want to use it, I have to deactivate then reactivate to get it to work.

When I say it doesn’t give full use I mean it only gives limited features, I have to ‘Search’ for artists or albums, I can’t just go to the Spotify section on Volumio and browse my favourite artists or albums, I can’t bring up genres?

It locks up if you don’t clear and play tracks, albums or radio stations, you can listen to either of those and when you change track or source it doesn’t always change, it says it does on the top right of screen but it doesn’t play. I usually have to close down the Volumio screen I’m using and then bring it back up again to see any changes in tracks or streams but that isn’t always successful.

Sorry but it it far too frustrating to use in its current state, once it gives​ full Spotify functionality then I’ll maybe try it again.

It might seem an odd question, but: where are you from?

We’re observing (and also other music players are) a funny behaviour of spotify’s API lately.

I fear this is related to the fact that spotify is about to discontinue libspotify and its gradually starting to disable it.
I’ve noticed it with my newly created playlists: they just do not show, while old ones do.

Aye that might be the issue, I’m in the UK, I’ll keep an eye on it and see if it improves.

I’m currently in the US, but I am running all my web traffic via TOR, while still strictly exiting in US. I’ve had Spotify via TOR on Volumio working in the past.

i’m from Belgium…

I’m from France.
I use Volumio since November 2016 : At first 2.041 release and now 2.118. I used before an “old” RPI 1 B+ and for 1 week an RPI 3 (with 2.118).
I choosed to keep “english” UI langage

if I add/remove playlist in my Spotify premium account (with my windows PC), I need to reboot Volumio to refresh Volumio Spotify “My favorite” playlists (No dynamic update)
If a Volumio spotify is running and if I choose another playlist and use “clear and play” function , the current playlist is stopped, the queue is cleared, but
the newer playlist is not add to the queue and not started…To start this new playlist i need to select again “clear and play” function.
I notice these problems with RPI1 B+, RPI 3, 2.041 and 2.118 releases.
Some weeks ago (RPI 1 B+, 2.041), I had a problem with a new playlist. I renamed it (there was an especial character in the name), restarted volumio.
I could access the playlist.

Otherwise, for now, it works pretty well.



Since my last post, I did a few tests:
I use an RPI3/IQaudio dac+/Volumio ver 2.119 (fresh install,not update) /Network Wire connection,Spotify Windows 10 App to manage my Spotify premium account (and playlists…), and I’m from France.
-About bug with Volumio “clear and play” function:
This bug exists not only with Spotify (You have it with music Library playlists…).
So util the bug will be fix, to change playlist the best way is to stop playing, in [Queue] tab, use “clear the Queue” icon, next in [Browse] tab select le newer playlist and “play” function in the menu.
About Spotify Playlists “bugs”:
After many attempts, I also found “bugs”, but it’s hard to define systematic rules.

You have to restart RPI to refresh the new Spotify volumio playlists (no dynamic refresh!). Maybe a refresh function could be included in Volumio?
Then, it depends on type of Spotify playlists:
-With playlists that you build yourself (as create a playlist from an album for example) no special problems : They are visible in Volumio.
-With playlists “follow” (created by another user or by Spotify that you follow), some of them are not visible in Volumio (I don’t know why!).
More strange,after many attempts to add/delete Spotify playlists with the Spotify Windows App, I noticed that the list of playlists seen by Volumio
did not change anymore! A deleted playlist under Windows Spotify App remained visible under Volumio and could be played !!!
So I used “Spotify web player” ,I noticed the list of playlists was different (deleted playlists were still visible), so I deleted the relevant playlists with
Spotify web player, and everything is back in order with Volumio. Maybe “Spotify web player” uses the same API than Volumio?
I think a “follow” playlist created a problem (and here, it shows an internal Spotify problem beetween Windows App and Web player !!!)
For these “problematics” playlists, it is possible to copy them in a playlist than you create yourself. It seems to work fine.

Sorry for my bad English.



Since my last post :
Today, I created new playlists in spotify (Windows App ou Web player) : There are not seen by volumio while old ones do… New playlists seems to be hidden…
On the other hand, if a had songs in an existing spotify playlist, there is no problems: It’can be see (and play) with Volumio.
Now, there are no difference between Windows App an Web player:Spotify web bugs are fix (see my last post).

I think that Libspotify is dying:frowning:
see :

Volumio 's Spotify pluging has to be reworked maybe with Spotify Web API (no so far of volumio concepts).

There are Node.JS samples.

Even though I come from windows programming world, I’m not competent enough to help to do that…



Today,the hidden playlists come back! I don’t know why: No change, no update, I have n’t had or remove playlists (I just shutdown rpi on last sunday, and restart today)

Very strange…

[(RPI3/IQaudio dac+/Volumio ver 2.119]