Spotify login problems

I have 3x Pi4-based Volumio 3 installations. All work fine apart from a weird issue I’m having with the Spotify Plugin on one device that I’d appreciate help with, please.

I have a Spotify Family account so I can dedicate an account to each Volumio device. Each Spotify account is named following a standard naming convention (Volumio_room@myemaildomain.com) and share the same password.

On two of the Volumio devices this works fine - on the third, it simply won’t accept the credentials and says Login Failed, check username and password. I’ve uninstalled and reinstalled the plugin, I’ve rebooted and I’ve even tried different accounts but nothing works.

Does anyone have any suggestions for debugging and correcting this, please?

I had the same issue yesterday, after a reinstall. Today I could connect to Spotify again. No idea what happened.

Thanks, @Wheaten - Did you change anything between the two times - or simply wait it out?

Didn’t change a thing. With 3 different accounts the same problem. What was weird the ones that were already installed had no issues connecting to Spotify, with one of these accounts.
Go figure…

That sounds identical to my issue! Weird, isn’t it. I’ll have to wait 24 hours and try again! Thanks.

Not sure what the reason is other than things happening at the Spotify end, but yes this is happening quite a few times.

@chsims1
I assume that for SPOP no connection is made to one of the Volumio servers, that might fail? As in the same time the new install (Odroid N2+) failed, my other 2 installations with Volumio connected to Spotify without any issues. (using one of these 3 accounts)

I tried again this morning - same problem.

I re-installed and it worked immediately. Same hardware, just a re-install.

Very strange but got it sorted, thanks.